This discussion has been locked.
You can no longer post new replies to this discussion. If you have a question you can start a new discussion

installing of RMcobol to a new Linux 64 bit fails to find eula.txt

When doing a fresh installation of RMCobol 12.19 the install.sh fails to find the eula.txt.  I see it in a subdirectory and copied it to the installation directory just incase it was a pathing issue but still install fails to get past that point.  

Tags:

  • Assuming this is Linux, find the subdirectory that contains INSTALL.sh (upper case is significant).  Change into that directory and run

    ./INSTALL.sh.  

    Perhaps that will work.

    UPDATE:  This is wrong info.  Apologies for incorrect info in this post.  Was extrapolating from a different product...

  • Thanks for reply, I did try to run it from the directory where install.sh is located.  I also copied the eula.txt to that folder just in case it was a pathing issue but still no luck.   Yes this is Ubuntu linux rel 22   going to try a support ticket and if they help me figure it out I will post answer here since this is a non starter if cannot even run the installation. 

  • Thanks for reply, tried that and copied eula.txt file to the installation folder in case it was a pathing problem.  No luck and yes this is ubuntu linux 22 fresh install up to date.  

  • Are you installing as root/superuser permissions?  

  • turns out didnt like my license file because it was for 32 bit not 64 bit.  Working with a support case on fixing that.  I changed to 32 bit and it got farther down the install but failed to validate the license.  So what I was doing is right just wrong version of the license. 

  • Bit-ness seems to be an issue.  I just got done installing 32-bit Relativity DataServer, on a 64 bit machine.  I had to bypass the install.sh script and install from a lower directory because install.sh saw 64-bit architecture and could not find the installation artifacts for 32-bit.  Support reports this probably will get fixed in v12.20.  RM/COBOL has a different install scheme, but still...