URGENT: After Production upgrade from 9.5.1 to 10.1 getting runtime errors

Specifically, stacks like this on all processes using Rumba:

at System.Windows.Forms.UnsafeNativeMethods.CoCreateInstance(Guid& clsid, Object punkOuter, Int32 context, Guid& iid)

   at System.Windows.Forms.AxHost.CreateWithLicense(String license, Guid clsid)

   at System.Windows.Forms.AxHost.CreateInstanceCore(Guid clsid)

   at System.Windows.Forms.AxHost.CreateInstance()

   at System.Windows.Forms.AxHost.GetOcxCreate()

   at System.Windows.Forms.AxHost.TransitionUpTo(Int32 state)

   at System.Windows.Forms.AxHost.CreateHandle()

   at System.Windows.Forms.Control.CreateControl(Boolean fIgnoreVisible)

   at System.Windows.Forms.Control.CreateControl(Boolean fIgnoreVisible)

   at System.Windows.Forms.AxHost.EndInit()

   at HostTools.frmTN3270Interface.InitializeComponent()

Parents
  • Verified Answer

    It would appear that the 10.1 installer should require a reboot (at least on Windows Server).  In our case, the IT person uninstalled 9.5.1, which it seems required a reboot.  He then installed 10.1 which it seems did not require a reboot.  So, although I don't know the underlying reason for the above behavior, once he rebooted the servers where 10.1 had been installed, the above issue disappeared.

Reply
  • Verified Answer

    It would appear that the 10.1 installer should require a reboot (at least on Windows Server).  In our case, the IT person uninstalled 9.5.1, which it seems required a reboot.  He then installed 10.1 which it seems did not require a reboot.  So, although I don't know the underlying reason for the above behavior, once he rebooted the servers where 10.1 had been installed, the above issue disappeared.

Children
No Data