This discussion has been locked.
You can no longer post new replies to this discussion. If you have a question you can start a new discussion

Visual Cobol for Visual Studio 2017 - Can't Uninstall or Repair

The vcvs2017_30.exe installer will not let me repair or uninstall my trial copy of Visual Cobol 3.0.

Here is the end of the log when I tried to uninstall:

02F0:0508][2017-09-02T00:36:49]i304: Verified existing payload: MFVSIXINSTALL at path: C:\ProgramData\Package Cache\13878A2A80E0CFE60A5AC97A3A35E19FA3CBD595\MFVSIXInstall.exe.
[02F0:0378][2017-09-02T00:36:49]i301: Applying execute package: MFVSIXINSTALL, action: Uninstall, path: C:\ProgramData\Package Cache\13878A2A80E0CFE60A5AC97A3A35E19FA3CBD595\MFVSIXInstall.exe, arguments: '"C:\ProgramData\Package Cache\13878A2A80E0CFE60A5AC97A3A35E19FA3CBD595\MFVSIXInstall.exe" -u -q'
[02F0:0378][2017-09-02T00:36:50]e000: Error 0x80004003: Process returned error: 0x80004003
[02F0:0378][2017-09-02T00:36:50]e000: Error 0x80004003: Failed to execute EXE package.
[1584:1664][2017-09-02T00:36:50]e000: Error 0x80004003: Failed to configure per-machine EXE package.
[1584:1664][2017-09-02T00:36:50]i319: Applied execute package: MFVSIXINSTALL, result: 0x80004003, restart: None
[1584:1664][2017-09-02T00:36:50]e000: Error 0x80004003: Failed to execute EXE package.
[1584:1664][2017-09-02T00:36:50]i399: Apply complete, result: 0x80004003, restart: None, ba requested restart:  No

I also get the same error code when trying to repair.

My Visual Studio 2017 Community edition works fine for C and C# but I don't see any Micro Focus options in the Help menu.

I did have to uninstall and reinstall Visual Studio 2017 because when I had tried to install the latest update from 15.3.2 to 15.3.3 failed.  When I did the unistallof VS2017, I had forgotten to first uninstall Visual Cobol 3.0, so that's probably the root cause of my problem.

I am still trying to use the trial version but have talked to my account manger to purchase VC 3.0

I am running Windows 10 with all the latest updates.

  • There is a command line utility called MFVSIXInstall.exe that can be used to install/uninstall Visual COBOL into VS2017

    Please see the documentation here.

    Chris Glazier
    Global Technical Support | OpenText

    If you found this post useful, give it a “Like” or click on "
    Verify Answer" under the "More" button

  • When I try to run it I get the following:

    C:\Program Files (x86)\Micro Focus\Visual COBOL\vsix>MFVSIXInstall -u
    Error 0x80004003: Object reference not set to an instance of an object.
  • I think you'd need to run mfvsixinstall with no parameters which by default will install the COBOL extension.
  • Tried that as well, same result:

    C:\Program Files (x86)\Micro Focus\Visual COBOL\vsix>MFVSIXInstall
    Error 0x80004003: Object reference not set to an instance of an object.
  • I suspect that's been triggered because VC has been uninstalled or is at least in an indeterminate state. Try running vcvs2017_30.exe novsix=1. This bypasses [un]installation of the Visual Studio extension. Try repair first but it's possible you may need to uninstall VC (then re-install as normal). After running repair try running mfvsixinstall again.
  • Tried running the vcvs2017_30.exe with the novsix=1 parm, but repairing still failed with error: 0x80004003.  Looking at the log, it still tried to execute MFVSIXInstall.exe  I've attached the log file, in case that is helpful.


  • Thanks for the log. Yes, it's still trying to run the uninstall. Can you bring up the Windows registry (regedit.exe) and browse for HKEY_LOCAL_MACHINE\Software\[WOW6432Node]\Micro Focus\Visual COBOL (specify WOW6432Node if on 64-bit Windows)? Selecting the Visual COBOL key you should have a key value in the right hand pane for 'DefaultVersion' (type REG_SZ, Data = 3.0). If that's gone missing it may cause the problems you describe. If missing try recreating the string value (right click in the right hand pane, select New ->String value and add that data). To test it out there's no need to install/uninstall - just run mfvsixinstall.
    If you expand the Visual COBOL key you should then have that version with values in the right hand pane (e.g. INSTALLDIR pointing to your installation folder).
  • The registry appears to be correct.  Here are a couple screen shots.

    MFVSIXInstall still fails with Error 0x80004003: Object reference not set to an instance of an object.

  • Verified Answer

    That all looks good and looks like you have VC installed. Instead of running mfvsixinstall try directly running the VS installer on our extensions. From a VS developer command prompt go to the VS15.0 folder (under the location where mfvsixinstall is) and run vsixinstaller VSCore.vsix. This is our primary COBOL integration (contains templates, editor colorization etc). Does this error, tell you the extension is already installed or offer the ability to install it? mfvsixinstall essentially does this but for all the .vsix files in this location.
  • That installed cleanly!

    I just rebooted and ran a simple command line Cobol program and it ran just fine.

    Thank you very much for your help.