This discussion has been locked.
You can no longer post new replies to this discussion. If you have a question you can start a new discussion

Visual Cobol for Visual Studio 2017 - Can't Uninstall or Repair

The vcvs2017_30.exe installer will not let me repair or uninstall my trial copy of Visual Cobol 3.0.

Here is the end of the log when I tried to uninstall:

02F0:0508][2017-09-02T00:36:49]i304: Verified existing payload: MFVSIXINSTALL at path: C:\ProgramData\Package Cache\13878A2A80E0CFE60A5AC97A3A35E19FA3CBD595\MFVSIXInstall.exe.
[02F0:0378][2017-09-02T00:36:49]i301: Applying execute package: MFVSIXINSTALL, action: Uninstall, path: C:\ProgramData\Package Cache\13878A2A80E0CFE60A5AC97A3A35E19FA3CBD595\MFVSIXInstall.exe, arguments: '"C:\ProgramData\Package Cache\13878A2A80E0CFE60A5AC97A3A35E19FA3CBD595\MFVSIXInstall.exe" -u -q'
[02F0:0378][2017-09-02T00:36:50]e000: Error 0x80004003: Process returned error: 0x80004003
[02F0:0378][2017-09-02T00:36:50]e000: Error 0x80004003: Failed to execute EXE package.
[1584:1664][2017-09-02T00:36:50]e000: Error 0x80004003: Failed to configure per-machine EXE package.
[1584:1664][2017-09-02T00:36:50]i319: Applied execute package: MFVSIXINSTALL, result: 0x80004003, restart: None
[1584:1664][2017-09-02T00:36:50]e000: Error 0x80004003: Failed to execute EXE package.
[1584:1664][2017-09-02T00:36:50]i399: Apply complete, result: 0x80004003, restart: None, ba requested restart:  No

I also get the same error code when trying to repair.

My Visual Studio 2017 Community edition works fine for C and C# but I don't see any Micro Focus options in the Help menu.

I did have to uninstall and reinstall Visual Studio 2017 because when I had tried to install the latest update from 15.3.2 to 15.3.3 failed.  When I did the unistallof VS2017, I had forgotten to first uninstall Visual Cobol 3.0, so that's probably the root cause of my problem.

I am still trying to use the trial version but have talked to my account manger to purchase VC 3.0

I am running Windows 10 with all the latest updates.