Behaviour of the Visual COBOL text editor

 We are moving from Net Express to Visual COBOL and a lot of the developers want the text editor in Visual COBOL to behave in the same way as the Net Express editor. I am aware of some of the settings you can make in Visual COBOL (e.g. enable virtual space), but I haven't found out how to get exactly the same behaviour. Is that even possible? Most problems arise when you paste code from other editors (and I posted a question about that some weeks ago and got the answer that that will be fixed in version 6), but there are other issues as well. So, is there a "Net Express" setting you can use in Visual COBOL?

  • The closest option to "Net Express mode" is called Smart Edit. This can be toggled on or off on the COBOL toolbar within the IDE. It can also be configured in Options / Micro Focus COBOL / Margins where there are several more options to control the specific behaviour of Smart Edit.

    The problem mentioned in other posts is due to settings not persisting after a certain update to Visual Studio 2019. This has been fixed in both the latest version of 5.0 and also the new 6.0 version of the product.

    Can you be more specific in the behaviour that is different from Net Express? Keep in mind that pasting code will, by default, automatically format the code for you and adjust it to your chosen source format. Pressing undo once will revert the automatic formatting. It can also be disabled entirely by disabling "Format on paste" in Options / Micro Focus COBOL / Formatting.