Open ESQL Assistant not loading

I have a full license for Visual Cobol 5.0 update 2 running in Visual Studio 2019 with all of the latest updates.

I am working through the Visual Cobol for Visual Studio Essentials online course and am to the section "Using the Open ESQL Assistant". 

I've confirmed in the Tools Options that the mode is ODBC.

When I select View -> Micro Focus SQL Tools -> OpenESQL Assistant, a new tab opens, but I don't see the window like in the tutorial.  It is simply blank.

I've rebooted several times, but the same result.  I am running Windows 10 (1903).

Does anyone have suggestions on how to resolve this?

Thank you.

  • Hi Mike,

    I can reproduce the behavior you are experiencing here. It actually happens with all of the SQL Tools available from the View menu. From the limited testing that I have done here, it didn't seem to happen on Windows builds prior to 1903.

    Can you please create a Support Incident for this and mention my name in the description and I will report it to development?


  • Verified Answer

    I believe that we have found the cause and a workaround for this issue. We have tracked it down to a combination of two Windows Updates. They are KB4519573 and KB4515871. When we uninstalled both of these the problem went away.

    Another, perhaps simpler workaround is to change a setting in Visual Studio. If you navigate to the Tools-->Options dialog and uncheck the red outlined option below "Optimize rendering for screens with different pixel densities (requires restart)". Click OK to confirm the change and then restart Visual Studio. (You do not need to restart your computer).

    Either one of these options solved the problem for us.



  • Thank you very much, Chris!

    I turned off the "Optimize rendering..." option and that did get it working.  I do wish the text wasn't so small though.  I've noticed that with other Micro Focus apps that it can be small (Like Micro Focus Data File Tools).  It's probably because I am running Visual Studio 2019 in a Windows 10 Parallels virtual machine on my Macbook Pro running macOS Catalina.  Unfortunately, I don't have a Windows PC to run Visual Studio.  That's not very user-friendly for people with visual disabilities, but at least on the Mac, I am able to zoom in on the screen to make it more readable.  

    I've attached a screenshot showing what the screen looks like. And another screenshot

    showing what the Data File Tools looks like.

    Should I still create a support ticket?

    Screen Shot 2019-28-10 at 22-51-24.png


    Screen Shot 2019-28-10 at 22-33-55.png

  • Hi Mike,

    Yes, please create a support ticket and then we can log the problem against your account. Even though we have a workaround we still need to investigate why these windows do not appear when the rendering option is turned on.

    On your screen shots I do not see that the Data File Editor is displaying in a small font but I have nothing to compare it with. For the OESQL Assistant it definitely looks incorrect on your screen but it looks fine on mine which is on a Windows 10 physical machine or on a Windows 10 VM. I am not sure we can fix that completely if it is dependent on the hardware but perhaps if the rendering option can be turned on then it may automatically address this too.

    Have you tried adjusting the computer screen display options such as resolution or scaling to make the text larger?

  • Hi Chris,

    I had the same issue opening Open ESQL Assistant and your solution unchecking optimize rendering for screen solved my issue. Should I also create a support ticket?


    Best Regards


  • Hi Alexander,

    There is really no need to open up an additional support ticket for this problem unless you wish to track the progress of the RPI (bug report) that I create. As you already have a viable workaround for the problem this is probably not necessary but it is entirely up to you.

    If you do create a ticket for this then please reference my name in the problem description so that it will be assigned to me.


  • Hi Chris,

    Yes, you're completely right. I will heed your advise and not create any ticket. Many thanks.


    Best Regards