Unable to download Visual Cobol 4.0 Patch Update 1

I'm unable to download the Patch Update 1 for 4.0 for Visual Studio 2017.

I get an error message indicating either "INET_E_DOWNLOAD_FAILURE" in Microsoft Edge or "ERR_CONNECTION_RESET" in Chrome.  In Firefox I get a message saying the connection was reset.

I do not use a proxy.

I tried both on my Windows 10 VM and on macOS

  • I just tested this under IE and Chrome under Windows 7 and Edge under Windows 10 and I was able to download the Patch Update 1 for 4.0 without a problem.

    Can you please try again?

    Thanks
  • I will try downloading again when I get home. I tried in both Chrome and Firefox on my work PC running Windows 7 and I also tried with Chrome on my personal computer, and I get a message saying that the site can’t be reached.
  •  Still no luck downloading the update.  Here is a screenshot of the error I get in Internet Explorer 11 on Windows 10.

  • Hi Mike,

    How did you request the download:- was it by navigating through the Product Updates section on the SupportLine site or was it some other route?

    Thanks
    Brian
  • Hi Brian,

    Yes, it was through the supportline.microfocus.com site. I click on "Product Updates" then "Search all updates available to you", click "Find Updates", check the box, click the plus next to "Visual COBOL for Visual Studio", click the plus next to "4.0 All Patch Updates", and then the down arrow next to "Patch Update 1 - 4.0 for Visual Studio 2017".

    I just tried again and it still fails with "Connection Reset"
  • This works fine for me as I just tried it again here.

    I believe the problem is something on your side Mike.

  • Mike, can you download anything else from the Product Updates page? I was wondering if this is limited to the Patch Update 1 or are you having issues with all product downloads from that page?

    Have you been able to download from this site in the past?

    This could be some kind of block from your network that is not allowing the downloads from this site.
  • Yes, this is almost certainly caused by either a middlebox (router, firewall, etc) or an application firewall. Since Mike tried two client machines running different OSes, it's more likely a middlebox.
  • So, I tried downloading 3.0 patch update 10, and that would have worked, as I got prompted by Firefox to save the file. I next tried 4.0 and that also prompted me to save the file. But when I tries again to download Patch Update 1 for 4.0, that again failed.

    I next removed OpenDNS as my DNS since it has some web filtering in it and tried again to download update 1 for VS2017 and it still failed. Next I tried downloading update 1 for the build tools and that prompted me to save the file. I next tried the update 1 for VS2015 and that also prompted me to save the file, but when I tried the update 1 for VS2013 that again failed.

    I did verify that my maintenance is valid through September 4, 2019 even though the Product Details page shows my version as 3.0.

    So, no solution yet, but a little more info.

    I did try to go to Supportline on my iPad, but can't mark the checkbox and so, I can't expand the product lists.
  • Mike,

    Can you please open up a support ticket for this and we will place the 4.0 PU1 installer on our ftp site for you to download while we investigate this problem?

    Thanks