Visual Cobol PE 2.2

This past weekend I first downloaded the 'Full' version of Visual COBOL for Visual Studio 2010 and installed it.  Then I discovered and downloaded

Visual COBOL PE V2.2.  I then installed the Personal Edition along with the already installed 'Full' Version but was confused about which one was

which and therefore 'Uninstalled' both and then tried to Install the Personal Edition by itself.  The Install kept getting the message:

'A required certificate is not within its Validity period when verifying against
the current system clock or timestamp in the signed file.'

I re-downloaded the PE version a couple of times and tried to Install it and kept getting the same error message.  I would then UnInstall

anything that was installed such as the Visual Studio and try again.  I even tried to install it on a Virtual Machine thinking there was something

left in the Register that kept the PE from installing.  I tried to clear out the register by running such software as 'CCleaner'.  Everyting

I tried did not work. 

I also was able to download  and Install version 2.1 of the Visual COBOL PE but did not see how to activate it beyound the 30 day trail period.

I need advice on how to get pass the error message when trying to install the PE version 2.2 and also how to activate it once installed.

Please include my email of bob@lasting-photos.com when responding.

Thanks,  Bob Moore  

 

 

  • This appears to be an issue with all of the product installers for the 2.2 GA products due to an expired certificate on one of the .msi files in the installer.

    Development is currently working on a fix and will refresh the product downloads with an updated version of 2.2 GA when available..

    The same problem does not exist with the 2.2 update 1 products only the 2.2 GA version.

    Unfortunately the Personal Edition product has not yet been updated to the 2.2 update 1 level so that is not an option for that particular product.

    If you have access to the full product release then you should download the 2.2 update 1 product and that should solve the problem.

    I will update this post when the fix for 2.2 GA and Personal Edition becomes available.

    Thanks.

  • Verified Answer

    Development has now fixed this problem and has replaced all of the 2.2 GA product installers with the new fixed versions.

    Please try downloading the Visual COBOL Personal Edition 2.2 product again and it should install fine.

    Thanks.