Visual Cobol personal edition debugging

Hi, when I try to start debugging with Visual Cobol Personal Edition (VS2012) I get "Unable to start debugging" (critical error). Someone else got the same error? Some idea before trying to reinstalling the product?.

Claudio

     

Tags:

  • Hi Claudio,

    I am afraid that you will have to give us some more information as this is not a known problem.

    On what OS do you have this installed?

    Which version of Visual COBOL is this 2.2?

    Does the debugging error occur on all projects or just this particular one?

    Can you open one of the examples in the Samples Browser from the Windows Start menu-->MF Visual COBOL group and debug it?

    Thanks.

  • Hi Chris,

    thank you for your answers. I have downloaded "Visual Cobol for Visual Studio Personal Edition v.2.2 0".

    It runs on Window 8.1 64 bit (Pentium x64). I do not have a web server on the machine so I tried only with Cobol Desktop:

    Create > New Project > Cobol Managed > desktop application > debug

    and I get

    Unable to start program 'c:\....'

    Operation not supported. Unknown error: 0x80040d10.

    If I launch the program without debugging it start normally.

    I have tried with a desktop Cobol Native Application setting a break point. Debug functions correctly.

  • Verified Answer

    According to a number of posts from Microsoft this problem appears to be caused by an installation problem that occurred during the install of Visual Studio or of one of the Visual Studio service packs.

    Performing an uninstall and reinstall of Visual Studio or the service pack in question appears to fix this problem.

    You might check the install .log which would be in your %TEMP% folder.

    Did you have a version of Visual Studio installed prior to installing Visual COBOL or were you installing into the default Visual Studio shell which is installed along with Visual COBOL?

  • Yes I have other versions of Visual Studio. I try to reinstall.

  • Hi Chris,

    uninstalling and reinstalling has not fixed the problem. I have many version of Visual Studio Installed (Store app, phone and Vs2013 for desktop). I have not found the install.log, the Application Event log does not report anything.

  • Hi again,

    I have downloaded the VS2010 version of Visual Cobol Personal Edition and all seems OK. (Debug start correctly)

    Thank you again, (Maybe I have too many versions of VS on my machine)

    Claudio