cannot create a project file

It appears I have successfully installed Visual Studio 17 and Visual Cobol for Visual Studio 17.  When I go through the process to create a project: File,new,project,intalled,cobol,native(same with any option), console application (or any option), complete the file name and hit 'OK' key, a Microsoft visual studio window appears stating it creating the project (name I entered).  It never completes and will not cancel.  I have to end visual studio from the task manager, endtask option ( three times ).

I do not have this problem with any other language, only visual cobol.  Same thing happens if I load a cobol program and attempt to create a project.  I can successfully compile the program and run from the debug choices, but that is where my capabilities appear to end.

Of course the question is:  How do I resolve the problem?

  • You may follow the steps below as there appears to be an issue with the licensing:

    1. Make sure to close License Administration and Visual Studio
    2. Make a backup of C:\ProgramData\Micro Focus\lservrc.stn
    3. Edit C:\ProgramData\Micro Focus\lservrc.stn
    4. Clear the content and save
    5. Go to Control Panel > Administrative Tools > Services
    6. Restart the "Sentinel RMS License Manager" service
    7. Start Visual Studio
    8. Select File > New > Project
    9. Choose COBOL > Native > Console Application, and a dialog about "Unable to find a license for Visual COBOL for Visual Studio on this machine" will appear
    10. Choose "I want to activate the free product"
    11. Enter email address
    12. Click Activate License
    13. After license is installed, close Visual Studio and open License Administration to check the license is present
  • I did as requested and it did not resolve the issue. The dialog screen asking me to activate the license never presented. When I hit ok, same results as described earlier happened. As a note, the iservrc.stn was empty. The license Admin program shows that I have a valid license - visual COBOL PE Visual Studio XXXXXXXXXXXX timed 357 (06/29/2019) Local 1 user.
  • A little more information. If I revoke the license, load Visual Studio, I can initiate a new or existing project after I respond to the window requiring me to activate my license. All goes well until I exit Visual Studio. Once I exit Visual studio, no project , new or old, will work.
  • Please email SupportLine@MicroFocus.com with your PE serial number and a description of the issue you are having. In the subject line add 'ATTN: Alex C' and I will have a look on Monday.
  • I have provided a new Authorization Code which was successfully activated but it appears the issue persists, at this point it appears that licensing is not the issues.

    This is the reply from the user:
    'I just tried your solution. Same result. It will work the first time, but when I exit and restart visual studio, it starts to open the project, but hangs up and will never open the project – ie: same result as before

    I looked and the Lservrc.net has new entries, but the Lservrc.stn is empty. For what ever reason, this solution does not solve the problem.'