Visual COBOL 3.0 PE for Visual Studio 2017 missing the documented subdirectory so I'm unable to launch the product.

I am doing a first-time installation of Visual COBOL 3.0 Personal Edition for Visual Studio 2017. This is for Windows 7 Professional SP1 64bit.

I have Visual Studio 2017 installed and can run that software. 

When I installed  Visual COBOL PE for Visual Studio 2017, I ran the standard installation but I apparently didn't get the needed product directories as indicated in the Release Guide that allow me to start/run the software.  The release guide says this for Windows 7:

From your desktop, click Start > All Programs > Micro Focus Visual

COBOL > Visual COBOL for Visual Studio 2017.

When I go to Start > All Programs > Microfocus Visual COBOL there is no subdirectory with that name in the next level down. I have: Samples, Configuration, Data Tools and Tools. But looking under each of those I find nothing that allows me to start Visual COBOL.

So what didn't happen correctly that I can't run the software?

  • With Visual Studio 2017 you have to run Visual Cobol from within Visual Studio. There is no separate app in the Micro Focus Visual COBOL folder.

    You create or open Visual COBOL projects from within Visual Studio 2017..

    I believe in prior versions of Visual Studio you were able to start Visual COBOL from a separate app.
  • Thanks Mike. That is definitely not what the Release Guide says to do. I notice that the manual has a few other discrepancies even just in the Installation section when referencing the MF Visual Studio levels. I looked in my VS-2017 for the options such as Debugging and Data Services being installed and I don't even find those options listed for VS-2017.

    But I'm in bigger trouble yet. When I installed this version of Visual COBOL for Visual Studio 2017 as well as my attempt to try the Visual COBOL Eclipse version, I end up with Java 8 installed. Java 8 (running two different update levels between the Visual Studio and Eclipse versions) is causing nothing but problems with Windows 7 Pro. Even Windows itself (things like the Windows/file Browser, Update Manager, Device Manager, etc.) don't function, the Office products launch but then go to "Not Responding" mode as soon as you try to do anything, and some of my software won't even launch at all. I just had to once again uninstall Visual COBOL and the Microfocus License Manager, then uninstall Java 8, reboot and all is well again.

    Since I'm not planning to do Java app development, I'm wondering if I can just uninstall Java 8 and still run Visual COBOL. But it seemed like when I tried to do that, the Java uninstall just sat there and wouldn't run (though I was working offline so I don't know if Oracle requires internet access to even do an uninstall) - UGH and UGLY.

    Since I'm new to this forum, is it better if I ask about the Java 8 as a separate thread?
  • Probably would be a good idea to start a separate topic.

    I have no experience with the Eclipse product, so I don't know if you can run both on the same system.

    I never was a fan of the Eclipse IDE, just didn't find it as intuitive as the Visual Studio IDE.

    It seems like Micro Focus doesn't pay that much detail to the documentation, probably assuming users will just learn how to use the product by using it, but personally, I like to refer to good documentation when I'm starting with a new product.
  • Hi eojkid. I work at Micro Focus on the documentation for Visual COBOL and I'd like to apologize for the inconvenience caused by the documentation inaccuracies that you refer to. I will arrange for someone in our writing team to look into this problem and make the required changes in a future update.

    If you have any additional feedback on the Visual COBOL documentation, please reply here or send an email to our docs feedback address (at

    Thank you.

    Mike Wilkin