Error 114 updating to Object COBOL 4.0.32

I'm at a loss...  We have some legacy applications that are compiled with Object COBOL 4.0.32 which was installed on an older desktop.  The desktop recently died and I'm now trying to install the compiler on a newer machine.  The machine is WinXP SP3 with 1GB RAM.  Nothing is running on it and I've disabled NAV, the firewall and everything in the BIOS set-up that looked like it might get in the way. 

I was able to install COBOL 4.0.07 and the WinSDK without a problem, but trying to run the 4.0.32 Update keeps throwing an error when it gets to "Checking Configuration...":

Execution error: file 'UPDATE' error code: 114, pc=0;call=1,seg=0 (Signal 11)

I have tried running it in Compatibility mode and unchecking the "Protect my files" option under "Run As" as well as running it as Administrator.  I have also tried Safe Mode in XP, a Win98 Virtual machine, running it from the command prompt, and I removed a 512MB RAM chip to see if it was an issue with too much memory. Oh and I did add the Update.exe to the "DEP" exception list.

I've googled the issue every which way I can think of, but so far nothing has helped.  Oh and I had a colleague try installing it on another older desktop running WinXP SP2 and she ran into the same issue, so I don't think it's machine-specific.

Also, I apologize if I'm posting this in the wrong place!

  • I did find an old KB article that suggest that the problem might actually be due to the setup.exe not being Y2K compliant:

    Error 114 when installing Object Cobol 4.0

    Product:   COBOL Developer Suite KB Number:   17299

    Product Family:   Workbench Date Published:   2003-05-05 00:00:00.000

    Problem

    Release: 4.0 This is due to the fact that the setup.exe file is not Y2K compatable.

    Resolution

    oinsthist.log (which is in the TEMP directry) setmfenv.bat (which is in the WINNT directory or where you have NT installed) COBOL32 (and subdirs. Or where you have installed COBOL) INSTALL.MF (directory) 2. Set the system date to a date before 1/1/2000. 3. Reboot the machine. 4. Install base product of Workbench (4.0.07) from CD. 5. Apply any updates required from ftp site: ftp.microfocus.com/.../cobol-workbench-v4.0 6. Reset system date back to today's. 7. Reboot the machine.  

  • Thank you for the suggestion, Chris.  MF released a "Fixy2K" patch some years ago that can be used to run the Setup - I used that and was able to install 4.0.07 without a problem.  It's the Update.exe for 4.0.32 that's now throwing the 114 error but just to be on the safe side, I did try setting the date back to 1998 and running the Update and it still threw it.  Sigh...  The strange thing is that I have loaded the Update several times in the past, even on XP and never had an error...

    Don't suppose you have any other suggestions?

  • Verified Answer

    FYI, I never did fix the update, but I was able to get a copy of the COBOL40 folder with the 4.0.32 version of the compiler.  I've copied it to the new machine and loaded the Sentinel driver (so that it could find the dongle), and I'm back in business.