Issue with Installation VisualCobol for Eclipse

Hello!

I try to install VisualCOBOL for Eclipse PE and every time get error related to missing Java.

At first I try to install in Windows 10 (x64) and receive error, that I must install Oracle Java 32bit not older than 1.6. I have installed Oracle JDK v.1.8 for x32 and x64. I found recommendation to install not so new version of JRE. Ok, I download and install v.1.7 and v.1.6 successively. and each time I receive the same error.


[2CC0:1004][2015-09-04T09:22:18]i301: Applying execute package: visualcoboleclipse22x86, action: Install, path: C:\ProgramData\Package Cache\{7BFAAF39-DCCF-4E2C-BF3C-B9101A9EA26A}v2.2.00244\Visual COBOL\visualcoboleclipse22x86.msi, arguments: ' ARPSYSTEMCOMPONENT="1" MSIFASTINSTALL="7" INSTALLDIR="C:\Program Files (x86)\Micro Focus\Visual COBOL" ECLIPSEINSTALLDIR="D:\eclipse\"'
[2CC0:211C][2015-09-04T09:22:18]i304: Verified existing payload: visualcoboleclipse22x64 at path: C:\ProgramData\Package Cache\{36FF2B25-510F-445E-B310-88D31C4E0858}v2.2.00244\Visual COBOL\visualcoboleclipse22x64.msi.
[2CC0:1004][2015-09-04T09:22:20]e000: Error 0x80070643: Failed to install MSI package.
[2CC0:1004][2015-09-04T09:22:20]e000: Error 0x80070643: Failed to execute MSI package.
[1BBC:2A98][2015-09-04T09:22:20]e000: Error 0x80070643: Failed to configure per-machine MSI package.


I am not set up any env. variable, because I don't found such requirement.

After that I try to install VisualCOBOL for ReHat PE. I use CentOS v7 (changed issue file as described on this forum), install all prerequisite libs and Oracle JDK 1.8 (including update PATH, JAVA_HOME and JRE_HOME), and again receive error, that I need to set up Oracle Java and add it to PATH. I try with JRE v.1.6, but result exactly the same again.

I haven't any idea, what I could try any more. May be someone could give some ideas?