VC 2.3 for VS 2015 - debugger problems

 At times the debugger will not process a line of code. This happens most often in trying to load a 2000 entry internal table in cobol .

i have tried to use move compute and set on one particular line of code thinking it might be the command but it still will not execute. Is the debugger part of VC or VS?

thanks 

  • Can you be more specific about what the debugger is actually doing?

    Are you stepping through the source code a line at a time and when it gets to a particular line it skips over it and will not highlight that line, or is it some other behavior?

    Is this managed code or native code?

    This normally is an indication that the .idy file is out of sync with the current source code so that the line numbers do not match up.
  • I'm stepping thru line by line and it will not hi-lite the line,but two lines down; a break point will also get set two lines down! It is managed code.
  • What is the best way to get the .idy file in sync with the source code
  • What is the best way to get the .idy file in sync with the source code
  • You can run Clean Solution from the Build of the project which should delete existing .idy files, etc. Under normal circumstances the idy files should always remain in sync if you are doing all of your builds from within the IDE using a project. If you are building outside of the IDE or are setting the COBIDY environment variable to point to other locations then it might pick up the wrong one.

    If you rebuild the entire solution and only have the single copy of the .idy file and the problem continues then perhaps it is a bug and should be reported through normal Customer Care channels. Since you are using V2.3 which is a couple versions behind the current V2.3.2 you might also try upgrading to the current version. If you are using the VC PE product then you will have to wait until the release of VC 3.0 PE which is due to be released later this summer.
  • Chris, I have run a clean on the solution and do all of my compiles in the IDE.Where can I check COBIDY? I have a registration request in to get v2.3.2 but haven't heard back yet; should I try a repair on VC and VS?
  • You would have to be setting COBIDY explicitly on your system either through Control Panel-->System or through a .bat file that you launch prior to starting the IDE. It doesn't sound as if this is the problem though.

    Try a Repair and see if it helps. If it does not then you can either wait until you receive a the 2.3 update 2 and try it for yourself or you can open up a ticket with Customer Care and we can take a look at what is happening on your system or test it under later releases ourselves if you can provide a demo.
  • I have tried the repair on both VC and VS With no luck. Guess I'll have to wait until my registration goes through and I get the new version. Thanks for the follow-ups.
  • Does your program have any copybooks?
    Try using something like process monitor to see where files are being picked up from to help track the problem down.

    technet.microsoft.com/.../bb795533.aspx

    Are you debugging by breaking into code using a CBL_DEBUGBREAK vs hitting F5 from within Visual COBOL?

    If you are using CBL_DEBUGBREAK, I have found it far better to actually have Visual COBOL and my project open rather than launch a new instance of Visual COBOL.

    Debugging GNT's is better done compiling in Visual COBOL than from a command line.

    Neil
  • Does your program have any copybooks?
    Try using something like process monitor to see where files are being picked up from to help track the problem down.

    technet.microsoft.com/.../bb795533.aspx

    Are you debugging by breaking into code using a CBL_DEBUGBREAK vs hitting F5 from within Visual COBOL?

    If you are using CBL_DEBUGBREAK, I have found it far better to actually have Visual COBOL and my project open rather than launch a new instance of Visual COBOL.

    Debugging GNT's is better done compiling in Visual COBOL than from a command line.

    Neil