Installation Error

# cat /etc/redhat-release
Red Hat Enterprise Linux Workstation release 7.1 (Maipo)

# java -version
java version "1.8.0_91"
Java(TM) SE Runtime Environment (build 1.8.0_91-b14)
Java HotSpot(TM) Server VM (build 25.91-b14, mixed mode)

# df -h
Filesystem      Size  Used Avail Use% Mounted on
/dev/sdb2        99G   33G   62G  35% /
devtmpfs        7.8G     0  7.8G   0% /dev
tmpfs           7.8G  152K  7.8G   1% /dev/shm
tmpfs           7.8G  9.0M  7.8G   1% /run
tmpfs           7.8G     0  7.8G   0% /sys/fs/cgroup

# ./setup_visualcobol_deveclipse_2.3_redhat_x86_64 -noplatformcheck
   Product will be installed to
      [ /opt/microfocus/VisualCOBOL ]

      Product  : Micro Focus Visual COBOL for Eclipse 2.3
      PRN      : KXCRH/AAD:Ao.U4.13
      Build ID : pkg_109427
.....
Do you agree to the terms of the License Agreement? (y/n): y

.......

install.sh - ExtractFiles - 001 - Failed to extract product
      due to lack of disk space. RC:- 254

Why  ? ---  I have 62GB free space

Really appreciated for the help!

  • # swapon -s

    Filename Type Size Used Priority

    /dev/dm-0                               partition 19922940 0 -1

    19GB for swap partition -- also far enough.

  • Hi Jack,

    The Release Notes document for Visual COBOL for Eclipse 2.3 on Red Hat indicates that the space requirement during installation is only 3.69 GB, so this does not appear to be a space issue.

    Are you able to (as root) manually create the parent of the target directory for the installation? You might try this using a command such as:

       mkdir -p /opt/microfocus

    If so, what does the df -h show on that directory?

    Also, I notice that in another community post from this past March, it appears you successfully installed this same product on a Red Hat machine. Is this a different machine? Are you still installing a Personal Edition of the product?

  • You may want to determine whether pax is installed. The installer uses pax to extract the binaries.

  • #ls /opt/microfocus

    logs  VisualCOBOL

    So I need to  remove  /opt/microfocus  first

    # rm -Rf /opt/microfocus

    Then, I create it

    # mkdir -p /opt/microfocus

    #cd /opt/microfocus

    # pwd

    /opt/microfocus

    # df -h

    Filesystem      Size  Used Avail Use% Mounted on

    /dev/sdb2        99G   31G   64G  33% /

    devtmpfs        7.8G     0  7.8G   0% /dev

    tmpfs           7.8G  208K  7.8G   1% /dev/shm

    tmpfs           7.8G  9.0M  7.8G   1% /run

    tmpfs           7.8G     0  7.8G   0% /sys/fs/cgroup

    So I can confirm  /opt/microfocus is in 64GB free space.

  • #yum install pax

    Resolving Dependencies

    --> Running transaction check

    ---> Package pax.x86_64 0:3.4-19.el7 will be installed

    --> Finished Dependency Resolution

    Dependencies Resolved

    ================================================================================

    Package       Arch             Version                 Repository         Size

    ================================================================================

    Installing:

    pax           x86_64           3.4-19.el7              RHEL71W            74 k

    Transaction Summary

    ================================================================================

    Install  1 Package

    Total download size: 74 k

    Installed size: 137 k

    Is this ok [y/d/N]: y

    Downloading packages:

    Running transaction check

    Running transaction test

    Transaction test succeeded

    Running transaction

     Installing : pax-3.4-19.el7.x86_64                                        1/1

     Verifying  : pax-3.4-19.el7.x86_64                                        1/1

    Installed:

     pax.x86_64 0:3.4-19.el7                                                      

    Complete!

    #export JAVA_HOME=/opt/jdk32

    #export PATH=/opt/jdk32/bin:$PATH

    #export LD_LIBRARY_PATH=/opt/jdk32/lib:/opt/jdk32/jre/lib:$LD_LIBRARY_PATH

    ./setup_visualcobol_deveclipse_2.3_redhat_x86_64 -noplatformcheck

       -=-==================================================================-=-

                       Micro Focus Product - Product Extractor

                                  www.microfocus.com

      Please Wait.

      Extracting Payload...

      Creating work area...

    ....

    Do you agree to the terms of the License Agreement? (y/n): y

    install.sh - ExtractFiles - 001 - Failed to extract product

         due to lack of disk space. RC:- 254

    Still the same error!

  • So,  free space and pax package are not the reason  for above error.

    I tried the installation on RHEL 7.2,  I got installation passed through,  but I can not start it -- only Eclipse, no COBOL components loaded.  I  tweaked it for a few of days to make it working.  

    Now I tried the installation on RHEL 7.1,  Then I got above error.

    It has never been an easy process for me.   I guess it will be the same for every newbie.

  • I have contacted Jack outside the forum to gather some additional information. I will update the forum as appropriate when the issue is resolved.

  • Verified Answer

    This issue is resolved. Basically, the customer had 2 issues:

    1) The product is tested and certified on Red Hat Enterprise Server, and he was trying to install it on Red Hat Enterprise Workstation; the installer fails because it does not recognize Workstation.

    2) There were several packages required by the product that were missing on the customer's machine. The required packages are listed in the Release Notes document for the product.

    Once the customer addressed these two issues, the install worked.

  • Visual COBOL is the development tools just like Microsoft Visual Studio.  Not a server product.

    Being certified on Workstation OS  makes more sense to developers.

    I expect 3 improvements in next release version of Visual COBOL:

    1. Being certified on Workstation OS,  at least  REDHAT Enterprise Workstation, even better if on Ubuntu LTS version.   --- I volunteer to be a tester !

    2. Using 64-bit Eclipse, because 32-bit Linux will be extinct and rarely used.  For EFI based computers (new PCs manufactured from year 2015),  there is even no way to install 32-bit Linux.  

    3. Installation process will  ask user to confirm (y/n) to install all dependencies (missing packages)  automatically,  not require user to install missing packages one by one manually.

    Thanks.

  • Hi jzhang, thanks for your feedback.

    Just wanted to let you know that many of the points you have made here should be resolved or greatly simplified in our next major product update.

    Now you have the product installed, I hope you're getting a chance to explore the features available for COBOL developers using Visual COBOL.

    Regards, Scot