Getting a license server error in Visual Studio 2019, mentions the localhost IP


I uninstalled and reinstalled Visual Studio 2019 to try to get rid of this error and it persists, and fails to create a new .  After reiinstalling Visual Studio, I started the vcvs2019_60 installer and chose the Repair option.

After I create a new COBOL project in Visual Studio, the license message re-appears and the new project is abandoned and is never created.

Any ideas?

  • 0  

    What is the exact error message you are getting?
    It sounds like you have no Visual COBOL license installed.

    From the Windows start menu navigate to Micro Focus License Manager and run the License Administration tool. On the Summary Tab what is displayed? Is there a full license installed?

    If not then you will need to install your license using the Install tab.

  • 0   in reply to Chris Glazier


    Good morning,

    My setup is Windows 10 and the 365 day trial version of Visual Studio and Visual Cobol.

    The error dialog I mentioned is from Visual Studio and reads thus:

    Unable to determine the status of the product license.

    Error details: Unable to determine the status of the product license.

    Error [5]: Cannot talk to the license server on host "", Server may not be running.

    I never got a window or dialog for Micro Focus License Manager, so there was no Summary tab info to be had.

    In an effort to remove a solution from Visual Studio yesterday, I uninstalled it and reinstalled it.  Then, seeing no COBOL templates or information, I ran the vcvs2019_60 installer again and chose "Repair installation."  That brought back the Micro Focus COBOL integration to Visual Studio, but I now get the Cannot talk to the license server on host "", Server may not be running. error from Visual Studio so I cannot proceed with my COBOL tutorial.

    Maybe I should uninstall/reinstall vcvs2019_60, but I will await your reply.


  • 0   in reply to Keith Christian

    The two services that need to be running are the Sentinel RMS Manager and the Micro Focus CES Daemon. Check these under Windows-> Services and make sure that they are started. Make sure that they are running under the Local System Account.

    You need to have a license installed in order to run the Visual COBOL product. If there is no summary page in the License Administration Tool then you will need to install the license key that was delivered in the download for your product. 

  • 0   in reply to Chris Glazier


    Both of the services mentioned above were running and I reinstalled the Visual COBOL license key and all seems well there.

    Visual Studio did not have any cobol support when I restarted it after fixing Visual COBOL, so I am uninstalling /reinstalling it so it can detect Visual COBOL, or I hope so.

    A few more questions:

    Can you point me to documentation for Visual COBOL 6.0 showing how to compile sample COBOL source code from the Windows CMD.EXE command line interface and then run it?  I have some sample COBOL-85 code that I would like to try out.

    Thank you again for your kind assistance.

  • 0   in reply to Keith Christian

    What edition of Visual Studio 2019 are you using? Professional, Enterprise, Community?

    You should not uninstall Visual Studio without first uninstalling Visual COBOL. Visual COBOL is an extension to Visual Studio so Visual Studio is required. You should try to uninstall Visual COBOL, repair Visual Studio and then reinstall Visual COBOL.

    The command line reference for the compiler and tools can be found here:

    If you are compiling and running from the command prompt you should really use a Visual COBOL command prompt which is available from the Micro Focus Visual COBOL group on the Start menu. This will automatically set up the environment so that the development tools and run-time system can be found. 

  • 0   in reply to Chris Glazier

    Chris, using the Community edition of Visual Studio 2019.

    Ok, copy on the "Micro Focus Visual COBOL group on the Start menu."

    Doubtless I may have more questions but I'll try to look them up on the web first.

    Thanks again.

  • 0   in reply to Keith Christian


    Installed vcvs2019_60 again after completely uninstalling and reinstalling it and Visual Studio 2019.

    More progress has been made but I still get license errors while going through this tutorial:

    I got a "License added successfully" message at the end of the Visual Cobol install.

    Both the CMS and RMS services that should be running are, and are running as Local System.

    I saw failures again while creating the "HelloCOBOLWorld" tutorial here:

    I was unable to complete the tutorial above due to more license errors, even though all looked correct in the post-license-install dialogs.

    I have a Wordpad file with screenshots if that will help.

    What are the next steps to troubleshoot this please?

    Thank you.

  • 0   in reply to Keith Christian

    Yes, please upload the wordpad file so that I can take a look at the screenshots. 

  • 0   in reply to Chris Glazier


    Ok, "upload" means using the "Insert" menu below the message?

    My 16 digit code is present in the screenshots, no way that the Wordpad upload will be visible to anyone but you, correct?

    I'll upload as soon as I get an answer from you.

  • 0   in reply to Keith Christian

    No it will be visible to everyone.

    Please email it directly to me at