Micro Focus license manager service is not running

Hi

When I create solutions in VCVS2019_6.0, importing from projects in Net Express, apparently they are generated without problems, and when I try to execute them, some go correctly and others give me the message "Micro Focus License Manager service is not running".
Why is this and how can I solve it?

If I try to execute them from the Command Interface,
Another type of message appears. (mf2 and mf3 displays)

 

Thank you

 

 

  • Can you open any of the native projects in the Samples Browser and run those programs? Is this just an issue with your converted Net Express projects? 

     

  • Hello,
    I have tried to open and run several samples that incorporate VCVS2019_60, and they work without any problem. Only, the incident that I report, occurs when I generate a new solution by importing from a Net Express project with version 6

    Solutions already generated by importing NE projects, with previous versions to the current one (VSVC2019_60), are executed and updated without problems .



  • Do you also have Net Express installed on this same computer? Perhaps there is a pathing issue where the Net Express run-time files are being picked up in error?

    Is it possible for you to zip up the converted project's folders and either attach them to this post or email them to me at chris.glazier@microfocus.com?

  • .

    Yes, I have Net Express installed on the same PC.

    I compress in a zip, the folder that contains everything and I send it to the email of **PERSONAL INFORMATION REMOVED**.

    Indicate that the process of generating a new solution from a project in NE, generates 4 cblproj projects, that initially includes the variable $saveprojectname$, as name of the executable projects or type lbr. Each project, by means of the option "download project" in VS, I edit it, changing $saveprojectname$ by the name of each project, it is saved, and it returns to "reload the project". and thus, when "recompiling the solution", it generates with the correct name each cblproj.

    The zip file, including the name of the NE project is called "nw2000.app", and the solution is created "mw2002.sln".

    Thank you

  • I have not yet received your email and I don't see it in my spam filter either.

    Can you try to resend please?

  • Hi,

    I send the mail at 16.00 to '**PERSONAL INFORMATION REMOVED**', as indicated in my mailbox, includes a 12MB  7z file.

    Now I include in this platform, the zip file of the project in question.

     

    Nw2000.zip
  • Hello GOYO,

    After reviewing your provided files, my colleague Chris Glazier has asked me to pass along the following reply: 

    It seems as if it is loading the file DSRUN.GNT from the file nomiaggnt.lbr. This is the Net Express version of the Dialog System run-time as in Visual COBOL the file is called DSRUN.DLL. You have to ensure that all of your executable files have been recompiled using VC and that you are not using any of the NX run-time files within your .lbr files.

     

  •  

    Hello,
    I have tried to remove from the NE projects I import, the DSRUN.GNT and also from the cblproj projects in VCVS2019_60.

    And now, when I try to recompile the solution, I get an error 

    "Link : Fatal error LNK1181 : cannot open input file kernel32.lib"

    On my PC, this file kernel32.lib,  appear on several folders, like

     C:\Program Files (x86)\Windows Kits\10\Lib\10.0.19041.0\um\x86.

    How do I synchronize VCVS2019_60, so that it finds, when compiling this file.

    Now I have installed Windows Software Development Kit Windows 10.0.19041.1.

    Regars

     

  • The Windows SDK and Build tools should have been installed automatically with the install of Visual COBOL. Removing the DSRUN.GNT from your build would have no effect on the new error that you are receiving.

    When the SDK and Build tools are installed by Visual COBOL the installer will set a registry entry that points to the location so that the LIB environment variable can be set to point to these before performing the cbllink.

    If you installed the SDK and Build tools yourself then there is a VC utility called cblms that can be used which will change the registry key to point to your installed location.

    Please see: Managing the Microsoft Build Tools and Windows SDK Packages (microfocus.com)

    You might also try to do a repair of Visual COBOL to see if that fixes the problem.

  •  I did a repair of Visual COBOL, and the problem with the LIB libraries was solved. 

    But the problem with "Micro Focus license manager service is not running",  continues, with most solutions created from importing projects into NetExpress, regardless of the problem, that all projects in the solution, initially when the whole solution is complicated, are given the name "$saveprojectname$", and requires downloading, editing and reloading each cblproj, replacing "$saveprojectname$" with the name of each project.

    I find that most of the generated solutions that when executed from the IDE, give MF License service is not running and when I execute them from the command interface, it works. I guess I need to have clear how to configure each cblproj generated with the solution when importing NE projects, and verify and adapt their properties according to an exe, lbr ...

     Thank you.