How do I enable X11 in PuTTY?

0 Likes
over 2 years ago

Problem

 

When trying to debug a program remotely using anim in a PuTTY terminal emulator, the X Terminal window doesn't pop up with the animator.

 

Solution

 

The problem is, PuTTY doesn't have X Terminal built in to it, MobaXterm does, so one solution would be to use MobaXterm. However, PuTTY can be configured to enable X Terminal.

You can test if X Terminal is working by using the xeyes command. A small window with a pair of eyes pops up with pupils that follow the mouse cursor. If these eyes do not pop up, then X Terminal has not been configured for X Terminal.

To configure PuTTY for X Terminal:

Start PuTTY

In the PuTTY configuration left panel click Connection->SSH->X11

In the right panel tick the 'Enable X11 forwarding' box and enter :0.0 in the 'X display location' box.

Back in the left panel click on Session and sign on as usual.

Once signed on enter the xeyes command to ensure X Terminal is working.

 

puttyconfig1.JPG

 

 

Comment List
Anonymous
Related Discussions
Recommended