UNIX Visual COBOL for Eclipse won’t start

0 Likes
over 8 years ago

Problem

UNIX Visual COBOL for Eclipse won’t start

 

Resolution

After investigation see below, for Oracle Linux 6.2.

Need to instal these packages using yum.

 

yum install gtk2-2.18.9-6.el6.i686

yum install PackageKit-gtk-module-0.5.8-19.0.1.el6.i686

yum install libcanberra-gtk2-0.22-1.el6.i686

 

Then eclipse will start okay.

[support@nwb-ora62sup bin]$ pwd

/home/products/vceclipse21/bin

[support@nwb-ora62sup bin]$ . ./cobsetenv

COBDIR set to /home/products/vceclipse21

[support@nwb-ora62sup bin]$ echo $JAVA_HOME

/usr/java/jdk1.7.0_13

[support@nwb-ora62sup bin]$ java -XshowSettings 2>&1 | grep "sun.arch.data.model"

    sun.arch.data.model = 32

Needs to be 32 bit

[support@nwb-ora62sup bin]$ eclipse

Starting Eclipse at Display localhost:10.0

   Please Wait...


Investigation


Just failed to start no error at all using normal user

Try as root user you should get some errors on the console.

See this article

http://www.eclipse.org/forums/index.php/t/262868/

Basically these three libraries missing


libgtk-x11-2.0.so.0, libpk-gtk-module.so, libcanberra-gtk-module.so

Do

yum provides "*/libpk-gtk-module.so"

you need the i686 package gtk2-2.18.9-6.el6.i686

yum install gtk2-2.18.9-6.el6.i686

To get more information you can run eclipse launcher from command line.

java -jar /home/products/vceclipse21/eclipse/eclipse/plugins/org.eclipse.equinox.launcher_1.2.0.v20110502.jar


This will give you some error logs in your home directory as well as screen output.

 

Comment List
Anonymous
Related Discussions
Recommended