Eclipse heap size 1

0 Likes
over 8 years ago

Problem

Error “COBCH1501S Insufficient memory”

Need to adjust Xms and Xmx settings in eclipse.ini

Solution

If you are doing large projects it is a good idea to increase the java HEAP size for your eclipse installation.

There is a file in the eclipse directory eclipse.ini that needs changing

To find this file Look at properties of visual COBOL start menu

Select properties

And highlight the start in directory

This should contain something like this.   

C:\Users\Public\Micro Focus\vc21upd1pkg70439\eclipse

Open window explorer and navigate to that directory.

In this directory edit the file using a editor I use notepad

change –Xms and –Xmx settings

There are many thoughts on values to use here maybe 512 fo Xms minimum size of memory

And 1024m for Xmx maximum size of memory or 1g

To look like this

Now close down eclipse if open and start eclipse again so we can check the settings have been applied.

Go to help>about eclipse

Then installation Details

Select configuration

And check the Xms and Xmx settings

And hopefully the insufficient memory error will go away.

If the size is too big for your machine and its current workload you will get a error like this.

And some details also

You need to adjust the settings down in the eclipse.ini kill some process’s on your machine or get more memory.

Note the eclipse version is 32 bit so from internet 3g or lower might be the maximum.

Comment List
Anonymous
Related Discussions
Recommended