Created On:  05 July 2011


In Visual Studio 2010 there is a setting to specify which extensions should be treated as COBOL copy files, like .cpy, .cob, .cbl etc.

How does one specify that a file without any extension should be treated as a COBOL copy file?


From the Visual Studio 2010 IDE menu navigate to Tools-->Options-->Text Editor-->COBOL-->Miscellaneous-->Copy file extensions.

Add a comma to the front of the list of extensions, by default this looks like:


change it to look like:


The "," means that a file with no extention will also be recognized as a copy file extension.

Incident #2525900