Wrong URL being sent in email

Hi all,


Small deployment just finalising the sharing of files by sending link. The URL being sent is incorrect in that it has http(s)://[internal_IP_Address]/filename etc. Whereas it should read http(s)://[FQDN]/filemname. I am using the postfix mail built in to Filr. it's probably staring me in th eface but I cannot find where to change the URL to reflect the FQDN. (obviously the internal IP will not work when being accessed externally).

Many thanks
  • ahennessy;2338158 wrote:
    Hi all,


    Small deployment just finalising the sharing of files by sending link. The URL being sent is incorrect in that it has http(s)://[internal_IP_Address]/filename etc. Whereas it should read http(s)://[FQDN]/filemname. I am using the postfix mail built in to Filr. it's probably staring me in th eface but I cannot find where to change the URL to reflect the FQDN. (obviously the internal IP will not work when being accessed externally).

    Many thanks


    That is strange... Did you specify FQDN when installing Filr? If you go into Filr appliance configuration and there under network, is the settings correct?

    Thomas
  • Yes, the hostname is correct. Mind you, I haven't sent too many emails since getting Postfix to work so i'll try another one and see if it has rectified.
  • ahennessy;2338168 wrote:
    Yes, the hostname is correct. Mind you, I haven't sent too many emails since getting Postfix to work so i'll try another one and see if it has rectified.


    Ah, so you are using the builtin postfix in Filr to send the mail?

    Thomas
  • Yes - got that working last week (been off for a few days) see my previous posts regarding postfix mail.

    I had it working is the previous version (1.01) but rebuilt when 1.1 came out and the correct url was being sent then - but not now. - typical.

    cheers
  • Ok so I tried to send the mail again both "email link" which fires up your own mail client and "email link using filr" and both had the following link [url]https://[InternalIP]:8443/ssf/s/readFile/share/11/-4550618197439382748/publicLink/DOC005.pdf[/url]. it really should only be https://FQDN/ssf/s/readFile/share/11/-4550618197439382748/publicLink/DOC005.pdf - No ip and no port.
  • "Share File" does send the correct link ? So I don't know where the other links are coming from.
  • ahennessy wrote:

    > Small deployment just finalising the sharing of files by sending link.
    > The URL being sent is incorrect in that it has
    > http(s)://[internal_IP_Address]/filename etc. Whereas it should read
    > http(s)://[FQDN]/filemname. I am using the postfix mail built in to
    > Filr. it's probably staring me in th eface but I cannot find where to
    > change the URL to reflect the FQDN. (obviously the internal IP will
    > not work when being accessed externally).


    Check the reverse proxy settings in the appliance admin console.
    That's what's used to build the URL in e-mail notifications.

    --
    Your world is on the move. http://www.novell.com/mobility/
    BrainShare 2014 is coming. http://www.novell.com/brainshare/
  • ahennessy wrote:

    > Small deployment just finalising the sharing of files by sending link.
    > The URL being sent is incorrect in that it has
    > http(s)://[internal_IP_Address]/filename etc. Whereas it should read
    > http(s)://[FQDN]/filemname. I am using the postfix mail built in to
    > Filr. it's probably staring me in th eface but I cannot find where to
    > change the URL to reflect the FQDN. (obviously the internal IP will
    > not work when being accessed externally).


    Check the reverse proxy settings in the appliance admin console.
    That's what's used to build the URL in e-mail notifications.

    --
    Your world is on the move. http://www.novell.com/mobility/
    BrainShare 2014 is coming. http://www.novell.com/brainshare/
  • Hi Jmarton,

    Yes I've checked the reverse proxy settings and they appear correct. The hostname is fine. I changed the hostname from [Filr.mydomain.com] to [url]https://[filr.mydomain.com][/url] and reconfigured and then tried [url]https://[external_IP[/url] address]. But it is still sending the emails as [url]https://[internal_IP]:8443[/url]. It has to be a setting somewhere alright - but where is the question...

    Any suggestions would be welcome.

    Thanks
  • I've rebuilt in large deployment (was a small deployment) and the same issue is occurring. The URL being sent by both "email link" and "Email link using Filr" is the internal IP address with port 8443 (e.g. https://192.168.1.1:8443/[otherstuff]). When I use Share File and send it to an external user the URL is 100% correct. The reverse proxy settings are correct as far as i can see. I'll open an SR to get it resolved if necessary.

    Thanks

    Anthony