Filr 1.1 "get file link" no permission

Fresh Upgrade to Filr 1.1 large deployment, no clusters and only one of each VA. Did not yet upgrade SQL VA. VMware ESXi 5

Hello,
I get the following message when I try to get a file link with the new desktop client in Windows 7: "You do not have sufficient permissions to perform this action."

I get this error when I try it from our Filr site: "You do not have right to share your selection."

I even gave all internal users all the sharing rights. I did all the prescribed post update tasks, LDAP, re-index etc. Other sharing methods work fine.

Any ideas?
Parents Reply Children
  • And how does one allow users to create file links from their Home Dir's?

    We have allowed our users to share file links under System - Share Settings and allowed this from all our Net Folders.

    Where is the setting to allow it from Home dir's? We still get the "you do not have the rights..."message when we try to generate a file link there.
  • mazzel;2340482 wrote:
    And how does one allow users to create file links from their Home Dir's?

    We have allowed our users to share file links under System - Share Settings and allowed this from all our Net Folders.

    Where is the setting to allow it from Home dir's? We still get the "you do not have the rights..."message when we try to generate a file link there.


    On the netfolder where the homedirs are located.

    Thomas
  • We have no netfolder for the homedirs.

    Our setup lets users access their homedirs from Filr from 'My Files' which has the personal store Home folder based on their homedir setting in EDir.
  • mazzel;2340486 wrote:
    We have no netfolder for the homedirs.

    Our setup lets users access their homedirs from Filr from 'My Files' which has the personal store Home folder based on their homedir setting in EDir.


    Okay but if I remember correctly the volume is added automatically as a netfolder if there are users homedirectories located on that volume.

    Just to be clear, you get this permissions error when you try to share a file from the homedir and not the personalstorage?

    THomas
  • There's no Netfolder containing our homedirs.

    We get the error both from the homedir (My Files - Home) and de personal store (directly under My Files)

    System - Personal store only has the option to allow/disallow and set quota for groups, no share options.
  • mazzel wrote:

    >
    > And how does one allow users to create file links from their Home
    > Dir's?
    >
    >
    > We have allowed our users to share file links under System - Share
    > Settings and allowed this from all our Net Folders.
    >
    > Where is the setting to allow it from Home dir's? We still get the
    > "you do not have the rights..."message when we try to generate a file
    > link there.


    The general system->share settings should govern what's allowed from
    home directories. If you go to users, user properites of one of the
    users getting the you do not have rights error, sharing, what do you
    see for file link? Is it set to allow or clear?

    --
    Your world is on the move. http://www.novell.com/mobility/
    Supercharge your IT knowledge. http://www.novell.com/techtalks/
  • aha, we're getting there! Thanks.

    The group under Share settings containing all our Filr users has the the File link checked since yesterday.

    I just checked the Workspace Share rights under Management - Users. It seems that about 10-15% have the File link as Allowed. Most of our users have it as Clear. Changing it to allowed per user fixes the issue. I guess I can check all users there and allow it for all at once.

    I will have to check what happens to newly added users to the system to see if they have the option as allowed from now on.