GWPOA - GWcheck to play nice

GW 8.0.3HP5-118623 Agents and GWIA running on OES 11 SP2 (SLES 11 SP3).
Soon to migrate to GW 2018 on OES 2018 (SLES 12 SP2)

Started a full Analyze/fix GWcheck for the PO on the POA. It took a long time and used the server resouces so much the clients could not funtion. And since this is a guest VM, all the rest of the VMs slowed right down and become unstable.

Is there a way to run the POA GWcheck in very low priority (mabe using the nice command) so it has low effect on the clients and other VMs? Would be great if low priority can be set for the GWcheck from C1. Don't care if the GWcheck takes 2 or more days as long as it doesn't intefere with the clients and other VMs.

If the later versions of GW have this option, then I can wait until the system is upgraded.

Any suggestions?
  • In article <johngoutbeck.8kkb80@no-mx.forums.microfocus.com>,
    Johngoutbeck wrote:
    > Is there a way to run the POA GWcheck in very low priority (mabe using
    > the nice command) so it has low effect on the clients and other VMs?
    > Would be great if low priority can be set for the GWcheck from C1.
    > Don't care if the GWcheck takes 2 or more days as long as it doesn't
    > intefere with the clients and other VMs.


    yes
    reduce the number of threads allocated to maintenance until it isn't a
    problem (POA restarts needed I believe)

    This resource use is why it is a good thing to schedule GWChecks for off
    hours, and when the basics are run regularly, the take less time when
    you need to do a one off fix.
    Http://www.konecnyad.ca/andyk/gwmnt5x.htm


    Andy of
    http://KonecnyConsulting.ca in Toronto
    Knowledge Partner
    http://forums.novell.com/member.php/75037-konecnya
    If you find a post helpful and are logged in the Web interface, please
    show your appreciation by clicking on the star below. Thanks!

  • Hello Andy;

    Thank you for the advice.

    I changed the POA Maintenance thread from default of 8 to 2. Didn't need to restart the POA, it updated the POA on the fly. Then performed a GWCheck. The threads at 2 allowed the users to keep working without performance issues.

    Thank you.
  • In article <johngoutbeck.8ks52n@no-mx.forums.microfocus.com>, Johngoutbeck
    wrote:
    > I changed the POA Maintenance thread from default of 8 to 2. Didn't need
    > to restart the POA, it updated the POA on the fly


    glad that did the trick.
    I guess when I last tried the setting, it was in the middle of a GWCheck.
    So I would guess that subsystem needs to be idle to take the change.


    Andy of
    http://KonecnyConsulting.ca in Toronto
    Knowledge Partner
    http://forums.novell.com/member.php/75037-konecnya
    If you find a post helpful and are logged in the Web interface, please
    show your appreciation by clicking on the star below. Thanks!