GroupWise Resource Rename Oddity

Running GW8.03 HF3 on fully patched Netware 6.5. Client build 105538 on Win XP.

We've recently renamed a couple of our GroupWise resources (both meeting rooms set as Places in their GW objects, both have been in place for years). Everything went fine, we created aliases for the old names and we can add new appointments. The accept/decline rules we have in place still run on them.

However, and I'm sure I'm not dreaming this, when you used to invite a Place to an appointment the client used to populate the Place field in the appointment automatically with the place you'd invited. Now it doesn't, this worked up until the rename, and I'm sure I didn't set anything up to make this happen, it did it out-of-the-box.

I have just tried creating a new Resource and it also doesn't put anything in there. So either I'm losing the plot or something odd is happening to new/modified Resources.

I have tried running an Analyze/Fix Databases (Structure Check) on the Meeting Room, it came back with no errors.

Any ideas? Or am I dreaming?