EMail causing GW 2014 Client to crash

I have a user who has been sent an email from a client, yet every time she tries to open the email GroupWise stops responding and crashes. Odlly enough, the email opens fine when using GW Webaccess. I've tried to forward the email on to myself but that causes the crash too.

I've installed the SP2 for 2014 client, that didn't work. I've completely uninstalled GW and reinstalled it, along with updating the Novell Client, but still no joy.

Does anybody have any suggestions that I could try?

Cheers,

D

Tags:

  • Hi D,

    Just a few things to check.... what happens if the user logs into GroupWise on a different workstation and attempts to open the mail? Does the mail contain any attachments?

    Please let us know - thanks.

    Cheers,
  • Hi Damian,

    You could try setting the client's Default Read View to plain text rather than html, sometimes the rendering in HTML can cause things to go a bit screwy.

    M
  • laurabuckley;2409298 wrote:
    Hi D,

    Just a few things to check.... what happens if the user logs into GroupWise on a different workstation and attempts to open the mail? Does the mail contain any attachments?

    Please let us know - thanks.

    Cheers,


    MarkDissington;2409302 wrote:
    Hi Damian,

    You could try setting the client's Default Read View to plain text rather than html, sometimes the rendering in HTML can cause things to go a bit screwy.

    M


    Hi Both,

    Thank you for getting back to me so quickly. Following your combined advice:

    I have logged in as the user to a terminal server via RDP. Opening the same email with GW still causes the crash i'm afraid. However, as Mark suggested, changing the default view from HTML to plain text seems to solve it, as I can then open up the email. Is it possible the fault exists with the sender, rather than with our GW client?
  • Hi,

    Yes, it is entirely possible that the mail is corrupt or poorly formatted. Do you know what backend e-mail system the sender is using? Could you get them to send a test message to you to see if this problem is repeatable?

    Looking forward to hearing back from you.

    Cheers,
  • Damian wrote:

    > I have logged in as the user to a terminal server via RDP. Opening the
    > same email with GW still causes the crash i'm afraid. However, as Mark
    > suggested, changing the default view from HTML to plain text seems to
    > solve it, as I can then open up the email. Is it possible the fault
    > exists with the sender, rather than with our GW client?


    Even if it's some sort of corrupt e-mail, it shouldn't cause the GW
    client to crash. I'd open an SR and submit the e-mail to NTS. The
    best way will be to forward the offending mail as an attachment to the
    NTS engineer who works your SR.

    --
    Your world is on the move. http://www.novell.com/mobility/
    Supercharge your IT knowledge. http://www.novell.com/techtalks/
  • Hello,

    I got the same issues with a Windows 10 Client with a specific HTML-Email from a Webform, send to my Email address.

    In Windows 7x64 (Novell Client 2 SP3 for Windows 7 (IR2)) the Groupwise Client 14.0.2 opens the Email correctly without any Problems.

    On the other Machine with Windows 10x64 and Groupwise 14.0.2 installed the Groupwise Client hangs on by opening the specific corrupted HTML-Email.
    Here is the Code with brings Groupwise to "hang on" on my Windows 10 System (with Novell Client 2 SP4 for Windows 10 (IR1)):


    Return-path: <user@domain.de>
    Received: from senddomain.net ([123.123.123.123])
    by mail.kreis-dueren.de with ESMTP; Mon, 26 Oct 2015 13:36:44 0100
    Received: from senddomain-rek.senddomain.net ([123.123.123.123] helo=domain.de)
    by senddomain.net stage1 with esmtp
    (Exim MailCleaner)
    id 1Zqgzy-00071G-Oc
    from <user@domain.de>; Mon, 26 Oct 2015 13:35:38 0100
    Received: from Webservername ([123.123.123.123]) by domain.de with Microsoft SMTPSVC(7.0.6002.18264);
    Mon, 26 Oct 2015 13:36:12 0100
    X-MailCleaner-SPF: none
    Date: Mon, 26 Oct 2015 13:36:12 0100
    Subject: =?utf-8?b?VGFzY2hlbmdlbGRib2Vyc2UgTmV1ZSBSZWdpc3RyaWVydW5n?=
    To: emailtoadress@gmx.de
    Mime-Version: 1.0
    Content-type: text/html; charset=1
    X-Mailer: PHP/5.3.1
    X-Sender-IP: 172.20.255.1
    Content-Transfer-Encoding: 8bit
    From: "myUserName" <user@domain.de>
    Reply-To: user@domain.de
    Message-ID: <SERVERNAMEBYbhyqZrVQld00000986@domain.de>
    X-OriginalArrivalTime: 26 Oct 2015 12:36:12.0385 (UTC) FILETIME=[E5DF8510:01D10FEA]
    Authentication-Results: antispam.providerdomain.net; dmarc=skipped
    X-NiceBayes: disabled (no database ?)
    X-Spamc: is not spam (score=-1.2, required=5.0)
    X-MailCleaner-Information: Please contact email@domain.net for more information
    X-MailCleaner-ID: 1Zqgzy-00071K-QV
    X-MailCleaner: Found to be clean
    X-MailCleaner-SpamCheck: not spam, Spamc (score=-1.2, required=5.0,
    MIME_HTML_ONLY 0.7, BAYES_00 -1.9, HTML_MESSAGE 0.0)
    X-MailCleaner-ReportURL: antispam.domain.net/rs.php


    <html>... here would be theHTML Email Content... </body></body></html>


    I changed the personal Data to email@domain and cut off the Emailbodytext.

    Maybe there is a issues with non correct HTML Headers. But I cant understand, why the Win7 System can open the Email and the Windows 10 System can not.
  • I could solve my issues by "repair" the edge browser in windows 10, which wasn't work probably on my system.
    Delete the "Microsoft.MicrosoftEdge_8wekyb3d8bbwe" Folder and run Powershell as administrator with command
    Get-AppXPackage -AllUsers -Name Microsoft.MicrosoftEdge | Foreach {Add-AppxPackage -DisableDevelopmentMode -Register "$($_.InstallLocation)\AppXManifest.xml" -Verbose}


    After that I could open the Email in GW14.02 with corrupted headers on my windows 10 machine.

    So it look like GW is using the browser engine from edge and not from ie11, which was also installed on the system.


    Regards
    Tino
  • In article <proenent.75fgdz@no-mx.forums.microfocus.com>, Proenent
    wrote:
    > So it look like GW is using the browser engine from edge and not from
    > ie11, which was also installed on the system.


    This would likely indicate that edge is the default web handler and not
    IE. Changing that may help as well and gives another idea to test if
    someone is experiencing a similar problem.
    Thanx for sharing your results so that we may all benefit.


    Andy of
    http://KonecnyConsulting.ca in Toronto
    Knowledge Partner
    http://forums.novell.com/member.php/75037-konecnya
    If you find a post helpful and are logged in the Web interface, please
    show your appreciation by clicking on the star below. Thanks!

  • In article <proenent.75fgdz@no-mx.forums.microfocus.com>, Proenent
    wrote:
    > So it look like GW is using the browser engine from edge and not from
    > ie11, which was also installed on the system.


    This would likely indicate that edge is the default web handler and not
    IE. Changing that may help as well and gives another idea to test if
    someone is experiencing a similar problem.
    Thanx for sharing your results so that we may all benefit.


    Andy of
    http://KonecnyConsulting.ca in Toronto
    Knowledge Partner
    http://forums.novell.com/member.php/75037-konecnya
    If you find a post helpful and are logged in the Web interface, please
    show your appreciation by clicking on the star below. Thanks!

  • In article <proenent.75fgdz@no-mx.forums.microfocus.com>, Proenent
    wrote:
    > So it look like GW is using the browser engine from edge and not from
    > ie11, which was also installed on the system.


    This would likely indicate that edge is the default web handler and not
    IE. Changing that may help as well and gives another idea to test if
    someone is experiencing a similar problem.
    Thanx for sharing your results so that we may all benefit.


    Andy of
    http://KonecnyConsulting.ca in Toronto
    Knowledge Partner
    http://forums.novell.com/member.php/75037-konecnya
    If you find a post helpful and are logged in the Web interface, please
    show your appreciation by clicking on the star below. Thanks!