groupwise version requirement discrepency

Since GMS 18 only works on SLES 12, I decided the first step in my overall GW18 upgrade would be to upgrade my GMS server from SLES 11SP4 to SLES12SP2 (with a further step to SP3 after, as per the GMS documentation).

The GMS 18 documentation here: https://www.novell.com/documentation/groupwise18/gwmob18_guide_install/data/inst_req_gw.html says that GMS 18 will work with GroupWise 2014 or later.

Therefore I decided after completing the SLES 12SP2 upgrade, I'd go ahead and install GMS18 so that part of the upgrade would be done. The installation stopped me pretty quick saying that GMS 18 requires Groupwise 18.0.0 or higher. When I answered "No" to the question of whether I had 18.0.0, the installation ended immediately.

I then proceeded to re-install the gms 14.2.2hp2 version, except using the SLES12 iso which I had wisely already transferred to the server just in case. That went fine and GMS is running on SLES 12SP2.

I'm assuming it's the documentation that's wrong, and that the GMS 18 install script has the hard stop for a good reason.

GMS 18 can't run against GW 2014?
  • Davemrm,

    > I'm assuming it's the documentation that's wrong, and that the GMS 18
    > install script has the hard stop for a good reason.
    >
    > GMS 18 can't run against GW 2014?


    It is indeed a bug against our documentation. GMS18 can run against
    any flavor of GW2014 as a post office however it is absolutely required
    that the owning domain has to be GW18. We have notified the doc folks
    so hopefully that will be updated soon.

    Pam

  • On Fri, 15 Dec 2017 19:04:02 GMT, davemrm
    <davemrm@no-mx.forums.microfocus.com> wrote:

    >
    >Since GMS 18 only works on SLES 12, I decided the first step in my
    >overall GW18 upgrade would be to upgrade my GMS server from SLES 11SP4
    >to SLES12SP2 (with a further step to SP3 after, as per the GMS
    >documentation).
    >
    >The GMS 18 documentation here:
    >https://www.novell.com/documentation/groupwise18/gwmob18_guide_install/data/inst_req_gw.html
    >says that GMS 18 will work with GroupWise 2014 or later.
    >
    >Therefore I decided after completing the SLES 12SP2 upgrade, I'd go
    >ahead and install GMS18 so that part of the upgrade would be done. The
    >installation stopped me pretty quick saying that GMS 18 requires
    >Groupwise 18.0.0 or higher. When I answered "No" to the question of
    >whether I had 18.0.0, the installation ended immediately.
    >
    >I then proceeded to re-install the gms 14.2.2hp2 version, except using
    >the SLES12 iso which I had wisely already transferred to the server just
    >in case. That went fine and GMS is running on SLES 12SP2.
    >
    >I'm assuming it's the documentation that's wrong, and that the GMS 18
    >install script has the hard stop for a good reason.
    >
    >GMS 18 can't run against GW 2014?


    Doesn't surprise me. Typically clients require the backend
    (domain/po) to be upgraded first. I don't recall if GMS was that
    particular in the past, but there must be something in 18 required to
    make it work properly now.

    But as a standard practice you always want to upgrade primary domain
    first and work your way down from there. Clients, Web Access, GMS
    should always occur afterwards.

    --
    Ken
    Knowledge Partner

    If this post was helpful and you are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

    Create and vote for enhancements!
    https://www.microfocus.com/products/enhancement-request.html
  • Hi,

    Documentation has been updated.

    Cheers,
  • KeN,

    > Doesn't surprise me. Typically clients require the backend
    > (domain/po) to be upgraded first. I don't recall if GMS was that
    > particular in the past, but there must be something in 18 required to
    > make it work properly now.


    It's the new licensing model that makes GMS 18 require the domain be
    GW18.

    Pam

  • Thanks all for the responses and quick documentation update. I should have mentioned that I was certainly thankful that the install script stopped me from installing, rather than just going ahead and then breaking everything. Of course I snapshotted my GMS server before starting so I could've just rolled back when it all turned to mud, but it would've rolled all the way back to SLES 11, undoing all my work. That reminds me, I guess I should remove the snapshot now since it's all happy at this interim stage of SLES 12SP2 GMS 14.2.2HP2.

    In regards to the licensing, it did occur to me that GMS 18 would need GW 18 to get the license, but I figured it would just run in the 90-day eval mode in absence of the GW 18 license piece.

    Ultimately I did still get most of what I needed done - the GMS server is running SLES 12 now, so it's ready for GMS 18.
  • Thank you. I wasn't aware of that yet.

    --
    Ken
    Knowledge Partner

    If this post was helpful and you are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

    Create and vote for enhancements!
    https://www.microfocus.com/products/enhancement-request.html