iManager 2.7.7 and GroupWise Plugins

iManager
Version 2.7.7 (20140113_1819)
Copyright (c) 1999-2013 Novell, Inc.
All rights reserved.
Field Patches:
Patch 1 -- 20140113

GroupWise Plugins
1.0.0.20131911


I modify a user select the GroupWise tab and receive this error: GroupWise configuration Error java.io.IOException: Server returned HTTP response code: 401 for URL: ' target='_blank'>https://ad-n1.osd:9710/gwadmin-service/list/USER?filter=ldapId eq '1641D236960BDB4DD7841641D236960B'

I click on the GroupWise Configuration tab and have the following settings:
Enter GroupWise Admin Service URL: https://ad-n1.osd <= this is resolvable from both my workstation and the iManager server.
Enter GroupWise Admin Service Port: 9710
Enter LDAP server ID: ldap-xl8 <= this is an LDAP server that has been configured in the GroupWise system.
Enter GroupWise Admin Username: Supervisor
Enter GroupWise Admin Password: <= I put the password in here and it accepts it without error.

Thanks,
David.
Parents

  • 1. can you plug the url into a browser and get a response?



    2. I suspect the admin service may be listening on the IP addr instead of hostname. To verify, from the GW server run:



    /opt/novell/groupwise/admin/gwadmin-ipc query



    you should get something like: 151.155.136.215:9710=>Utah(/mail/utah/)




    What you enter in the iMan plugin config needs to match what the admin service is listening on..



    --Morris



    >>> dbenjamin<dbenjamin@no-mx.forums.novell.com> 8/19/2014 1:06 PM >>>




    iManager
    Version 2.7.7 (20140113_1819)
    Copyright (c) 1999-2013 Novell, Inc.
    All rights reserved.
    Field Patches:
    Patch 1 -- 20140113

    GroupWise Plugins
    1.0.0.20131911


    I modify a user select the GroupWise tab and receive this error:
    GroupWise configuration Error java.io.IOException: Server returned HTTP
    response code: 401 for URL:
    ' target='_blank'>https://ad-n1.osd:9710/gwadmin-service/list/USER?filter=ldapId eq '1641D236960BDB4DD7841641D236960B'

    I click on the GroupWise Configuration tab and have the following
    settings:
    Enter GroupWise Admin Service URL: https://ad-n1.osd <= this is
    resolvable from both my workstation and the iManager server.
    Enter GroupWise Admin Service Port: 9710
    Enter LDAP server ID: ldap-xl8 <= this is an LDAP server that has
    been configured in the GroupWise system.
    Enter GroupWise Admin Username: Supervisor
    Enter GroupWise Admin Password: <= I put the password in here and
    it accepts it without error.

    Thanks,
    David.


    --
    dbenjamin
    ------------------------------------------------------------------------
    dbenjamin's Profile: https://forums.novell.com/member.php?userid=6774
    View this thread: https://forums.novell.com/showthread.php?t=478853
  • Hello, im having a similar problem.

    I can acess to the the groupwise tab on imanager and select the poa that i want to associate a user then i click apply. But the changes are not really applied. The groupwise user is not created.

    my output of /opt/novell/groupwise/admin/gwadmin-ipc query is:


    0.0.0.0:9710=>MAIL
    10.10.240.113:9711=>POA01.MAIL

    I can't understand what's wrong with this

    Thanks in advance.

    mblackham;2329964 wrote:
    1. can you plug the url into a browser and get a response?



    2. I suspect the admin service may be listening on the IP addr instead of hostname. To verify, from the GW server run:



    /opt/novell/groupwise/admin/gwadmin-ipc query



    you should get something like: 151.155.136.215:9710=>Utah(/mail/utah/)




    What you enter in the iMan plugin config needs to match what the admin service is listening on..



    --Morris



    >>> dbenjamin<dbenjamin@no-mx.forums.novell.com> 8/19/2014 1:06 PM >>>




    iManager
    Version 2.7.7 (20140113_1819)
    Copyright (c) 1999-2013 Novell, Inc.
    All rights reserved.
    Field Patches:
    Patch 1 -- 20140113

    GroupWise Plugins
    1.0.0.20131911


    I modify a user select the GroupWise tab and receive this error:
    GroupWise configuration Error java.io.IOException: Server returned HTTP
    response code: 401 for URL:
    ' target='_blank'>https://ad-n1.osd:9710/gwadmin-service/list/USER?filter=ldapId eq '1641D236960BDB4DD7841641D236960B'

    I click on the GroupWise Configuration tab and have the following
    settings:
    Enter GroupWise Admin Service URL: https://ad-n1.osd <= this is
    resolvable from both my workstation and the iManager server.
    Enter GroupWise Admin Service Port: 9710
    Enter LDAP server ID: ldap-xl8 <= this is an LDAP server that has
    been configured in the GroupWise system.
    Enter GroupWise Admin Username: Supervisor
    Enter GroupWise Admin Password: <= I put the password in here and
    it accepts it without error.

    Thanks,
    David.


    --
    dbenjamin
    ------------------------------------------------------------------------
    dbenjamin's Profile: https://forums.novell.com/member.php?userid=6774
    View this thread: https://forums.novell.com/showthread.php?t=478853
  • Hello...

    Long time dead thread I know ... But i'm struggling with the same.

    We have 5 sites. and we have just installed a file server on one of our sites that only had groupwise until now. It's running GW2014R2HP1 and The fileserver is OES2015 running iManager 2.7.7

    I am trying to configure iManager plugin for Groupwise and getting similar errors.

    So i've tried to connect it to our main sites groupwise admin.

    loughoes2:/opt/novell/groupwise/admin # ./gwadmin-ipc query
    10.100.102.225:9711=>Loughborough.lghdom(/mnt/grpwise/lghpo)
    10.100.102.225:9710=>lghdom(/mnt/grpwise/lghdom)

    Then I tried connecting it just to the local groupwise server on the same site as itself as really we want the staff there logging on and only looking at their own part of the tree...
    so tried connecting it to their local groupwise server

    lanoes1:~ # cd /opt/novell/groupwise/admin/
    lanoes1:/opt/novell/groupwise/admin # ./gwadmin-ipc query
    0.0.0.0:9710=>landom(/mnt/GRPWISE/landom)
    0.0.0.0:9711=>Lancaster.landom(/mnt/GRPWISE/lanpo)

    So I tried in the Groupwise connector
    Admin Service URL: https://192.67.50.70
    Admin Service Port: 9710
    Groupwise Directory Name: 192.67.50.70 also tried landom
    Username: same as i use on the web interface
    Password: same as i use on the web interface

    Either way with landom or 192.67.50.70 I get 401 errors.
    GroupWise Configuration Error - java.io.IOException: Server returned HTTP response code: 401 for URL: ' target='_blank'>https://192.67.50.70:9710/gwadmin-service/list/USER?filter=ldapId eq '************'
    Any help / advice would be appreciated
    Thanks

    Steph
  • OK. I found a solution that seemed to fix it allowing it to connect...

    I opened it in IE instead of Firefox, it's like firefox isn't actually saving the password on the page. when I did it in IE it then saved the password and connected.
Reply Children
No Data