GroupWise 2018 client install fails to copy files

Using the GW 18.2 client win32 dir, I copied the whole dir up to a shared location, then created a ZCM bundle to install it using the gwtuner app to make an MST.  On the first Windows 7 machine (yeah I know, out of support) I tried to run the install on, it worked properly. 

On the second Windows 7 machine the install failed saying it couldn't find these source files, but they existed in the source directory and the install program had already copied other files to the destination so it had access to the source.  Also, on the destination WS, I could browse to the files.  One file, that the error dialog said it was looking for, gwclu1us.dll, doesn't exist in the source location but a similar file, gwclu1en.dll, does so I copied that.

gwshl1en.dll  -  exists in source

gwclu1us.dll  - doesn’t exist in source but gwclu1en.dll does

gwmxl1en.dll – exists in source

gwmim1en.dll – exists in source

gwabdgen.dll -  exists in source

Is this a known problem??

Dan

  • Looks like I can't use a ZENworks MSI app and the Grpwise MSI and MST.  I have to use the setup.exe file and customize it with setup.cfg and setup.ini.  I thought the install program would have been a little more advanced than that .

    Dan

  • Dan,

    I use the gwtuner.exe file to create an MST file.

    Then my ZCM bundle copies the following files locally:

    * extract_setupip_packs.cmd
    * setupip.fil
    * setupip.en

    I run extract_setupip_packs.cmd and then add my MST file to the created folder structure.

    Then I launch C:\Windows\System32\msiexec.exe /i C:\ZCM\gw18\win32\groupwise.msi /qb-!

    I have a requirements section that makes sure the necessary dotNet and VC prerequisites are met prior to this running.  I've been doing this for a while without a hitch.

     

  • Ken, thanks for the info.  That sounds a lot more complicated than what I have been doing in the past.  I would put the GW client dir up on a shared drive, then create a simple Windows bundle that just launches setup.exe from the shared directory.  I modify setup.cfg to have some control over the install; I set it to only show progress then show the finish screen and I include the DNS name I want GW to point to.  It seems to work fine that way.

    I just did this for 2018 and it seems to run OK with the exception of it taking forever to install the MS Run Time libraries.  Have you found any way to speed that up?

    Dan

  • My install method does not include the runtimes.  The Autodesk software we use installs all the runtimes that are also required by GroupWise.  So I just create requirements to make sure they are installed.

    I've attached the steps I take.  Once the bundle is created, it is fairly simple to update it for newer versions.  I just make a copy of the bundle, update the files, and change the grpwise.exe version requirement.

    There are probably other ways to do this, but I have found this one to work consistently in our environment.