SMTP AUTH wirh GW2012 GWIA

Hi,

I want tp set up a SMTP Relay connection to our internet provider and set the message host to their ip adress of the relay.

They asked me to set up SMTP AUTH on this connection.

How can I do this with GWIA?

Bye

Alfons

Tags:

  • Hi Alfons,

    For outbound authentication to other SMTP hosts, the Internet Agent requires that the remote SMTP hosts support the AUTH LOGIN authentication method. To set up outbound authentication:

    Include the remote SMTP host’s domain name an authentication credentials in the gwauth.cfg file, located in the domain\wpgate\gwia directory. The format is:

    domain_name authuser authpassword

    For example:

    smtp.novell.com remotehost novell

    If you have multiple SMTP hosts that require authentication before they accept messages from your system, create an entry for each host. Make sure to include a hard return after the last entry.

    If you want to allow the Internet Agent to send messages only to SMTP hosts listed in the gwauth.cfg file, use the following startup switch:

    /forceoutboundauth

    With the /forceoutboundauth switch enabled, if a message is sent to an SMTP host not listed in the gwauth.cfg file, the sender receives an Undeliverable message.

    Hope that this helps you :)

    Cheers,
  • Hi Laura,

    I put in the the -mh with the adress of the smtp relay and the AUTH parms in wpgate\gwia\gwauth.cfg.

    The only message I receive ist a "535 auth failure" which comes not from the smtp relay but from our own GW system

    Strange ?!?!

    Bye

    Alfons
  • Hi Alfons,

    Did you put the domain name of the remote SMTP server in the auth file or your own?

    Cheers,
  • * Alfons wrote, On 01/24/2014 03:36 PM:
    > The only message I receive ist a "535 auth failure" which comes not from
    > the smtp relay but from our own GW system


    How? If you receive the error by mail, it is probably your GWIA receiving the error message from the remote SMTP server and sending it to you.
    Else what Laura said. Test it with any SMTP client connecting directly to the remote SMTP server, and use the exact credentials in the gwauth.cfg

    Uwe

    --
    Novell Knowledge Associate
    Please don't send me support related e-mail unless I ask you to do so.
  • laurabuckley;2302908 wrote:
    Hi Alfons,

    Did you put the domain name of the remote SMTP server in the auth file or your own?

    Cheers,



    Hi Laura,

    the entry is "mail.zeus07.de" which is the mail server at the provider.

    If I telnet there using port 25 a mail server responds to this.

    My provider told me to active a SMTP AUTH switch in my mail system bute where is this in the GWIA config ???

    Bye

    Alfons
  • Hi Alfons,

    Here's the documentation reference: http://www.novell.com/documentation/groupwise2012/gw2012_guide_admin/data/aj8xozk.html#ak7t0r9

    There is no SMTP AUTH switch in the gwia.cfg file - I think that they are referring to an Exchange setup.

    The gwauth.cfg is what invokes this setting.

    You can force outbound authentication by using the --forceoutboundauth setting in the gwia.cfg, but just note that if you try to send to any other system not specified in the auth file, it will fail. If you are simply sending all outbound mail to one specific relay host that should not be a problem.

    In the gwauth.cfg file, ensure that you have put a hard return [enter] at the end of the line with the domain name and credentials - it won't work without this!

    Let us know how it goes.

    Cheers,
  • Hello, Laura,

    ok, thank you for this information.

    We now had success with our gwia - config using the following input:

    1) gwia.cfrg with mh mail.zeus07.de and switched off the /forceoutboundauth there

    2) put in correct information in gwauth.cfg :

    mail.zeus07.de user passwort

    The /forceoutputauth results in message like this : ovi.com is not an correct AUTH domain

    Leaving this switch in the config sends all mails to our provider as an SMTP gateway.

    Bye

    Alfons
  • Hi Alfons,

    Thank you for the feedback. Glad that you got it working :)

    Cheers,