Problems Upgrading GW Mobile server to SLES 12

I'm trying to upgrade Groupwise Mobile from running on a SLES 11 sp4 VM to SLES 12 SP4.

We're already running Server Name: GW-Mobile Version: 2.1.0 Build: 230, so I don't think I need any updates to this, since, shockingly, this hasn't been updated since 2015.

Having said that, in the instructions:

https://www.novell.com/documentation/groupwisemobility2014r2/gwmob2014r2_guide_install/data/inst_update_mobility_pack.html

The instructions are: "Run /opt/novell/datasync/tools/pgUpdate.sh to update postgresql. This can be done at any time before upgrading the OS."

Which is supposed to upgrade the Postgres SQL to 9.4 from our existing version 8.3.23.

This file does not exist.

Have I missed something?

I have tried to update Postgres SQL manually using zypper: zypper install postgresql94-contrib but this seems to break the dashboard, and likely other things as well.

Please help me figure out where I've gone wrong here.

  • For starters, your GMS is too old.  On that same page you reference, it states:

    Upgrading from SLES 11 to SLES 12
    Before you can upgrade from SLES 11 to SLES 12, the following prerequisites must be met:

    * GMS 14.2.1 HP1 must be installed on the SLES 11 server before the upgrade to SLES 12.

    14.2.1 HP1 is Build 270 and you are at Build 230.  The current version is (I think)18.1.1 Build: 483.  So you are missing out on a lot of newer fixes/features.

    My recommendation would be to build a new SLES 12 server and install the latest GMS on it.  You can set it up in tandem with your existing GMS and get it synced up with GroupWise and then point your DNS to the new server and people will seemlessly move over to the new server.  I have done it with my 75 user system and only had a couple people that needed to delete the mailbox on their mobile device and then re-add it.  Everyone else just kept working as if nothing had happened.

  • We are not running Groupwise 2018, so I didn't want to go that far. I need to get all my Groupwise Servers upgraded to SLES 12 before I migrate to GW 2018. And we have several.

    I'm just really trying to upgrade the operating system behind it, and make sure that the database underneath it is also upgraded. per the instructions.

    You said: "GMS 14.2.1 HP1 must be installed on the SLES 11 server" Maybe something is being lost in translation here: Isn't GMS 2.1 the same as 14.2.1 HP1? The naming conventions here are strange and I'm not sure how to determine what version numbers are comparable in that sense.

    In this sense, I'm at the latest version for 2014 r2, I BELIEVE; but why does the script that upgrades the Postgres SQL not exist? It seems that this is my missing link, preventing me from moving forward.

  • Also, I downloaded the latest (I thought) GMS ISO from my Customer Center and it's also listed as 230, so I assumed it was the latest.
  • Isn't GMS 2.1 the same as 14.2.1 HP1?

    No it is not.  That is the issue.  I was hoping MicroFocus had a build history for GMS that I could point you to, but I cannot find one.  But you need to get to at least 14.2.1 HP1 before you can upgrade SLES.  I'm not sure of the exact release date for 14.2.1 HP1, but I installed it on my system in January 2017, so it was probably released some time late 2016.  You have two options: 

    1. Upgrade GMS to 14.2.1 HP1 and then upgrade SLES, or

    2. Setup a new SLES 12 server and install GMS 14.2.1 HP1 (using the method I mentioned).

    The choice is yours.  The benefit to #2 is little to no downtime.

  • This sounds like a good plan. I've filed an SR with Microfocus about why I'm not seeing versions past 230 in my Customer Center, and hopefully the version 270 is the GMS 14.2.1 HP1 you mentioned. No wonder I was confused.

    Hopefully the GMS 14.2.1 (270) will contain the script I need (/opt/novell/datasync/tools/pgUpdate.sh" to get PostgresSQL updated also.
  • Unfortunately no one in support has access to your customer care portal.   You will need to email entitlements@microfocus.com

    Pam

  • You might want to email entitlements@microfocus.com to see if something is missing in your Customer Center.  The 230 build is too old for SLES 12.

     

  • I have downloaded and installed all these patches, and yet my original question remains unanswered. I still need to upgrade PostgreSQL from 8.3 to 9.4, and I appear to be missing (still) the script that is supposed to do this upgrade.

    Manually updating the database breaks the Dashboard, and installing GroupWise Mobility Service 2014.R2.Support Pack 2.Hot Patch 5 (14.2.2.5) doesn't provide me with a mechanism to update the database.

    So, my question, while answered beyond my original awareness is still stuck at the initial question.

  • 14.2.2.5 (i.e. build 255) should contain

    datasync-common-14.2.2.7781-1.1

    So if you run something like

    rpm -qa |grep -i datasync-common-1 |xargs rpm -ql

    you should get these ones

    /opt/novell/datasync/tools/pgUpdate.sh
    /opt/novell/datasync/tools/pgUpdate94to96.sh

    listed. If not something's gone wrong on updating. And for sure build 225 hasn't been the first one to contain the scripts.

     

     

  • Does the pgUpdate94to96.sh also upgrade you from 8.3 to 9.4 first?
    If not, how do I get the script that does this?