Cannot run rebuild on PO databases : Error PKIX path validation

Hello..So i'm in the midst of testing migrating my Post offices to another server. running GW 18.1.1 133172. Following TID 7024374..The primary domain has been moved. New certs. After the primary domain moved,  the certs were updated on the secondary domain using gwadminutil certinst -db /pathtosecondary -ca IPofprimary:9710 -a admin -p password.

The secondary domain has POs on it as well. (I did not know if I had to update the certs for the POs on this box as well, but I didn't do this ).

Now the  secondary Secondary domain is now moved to  its own server again downloaded the certs to this new box. Everything looks to be happy. 

The plan is to now move the  POs will be going to another server. 


When I try to validate the PO from the GW admin console before I move it (or do any database function on the PO) I get this error: PKIX path validation failed: signature check failed (null)

Everything else is up and running and the system is working. I tried to recreate the admin.crt for the PO using the gwadminutil certinst command and also rebuilt the PO manually (did this on its owning domain then copied the wphost file to the PO server) but I'm still getting this error.

I also try to regenerate the SSL cert on Post office and it gives me the same error? Then when I try to browse to the location of cert it says "Unable to retrieve information from the remote system."

Ugh. Any ideas what is going on?

I assume it's the admin certs that are having an issue but I'm just not sure why?