GW 2014 Calendar Publishing Host Events Display In GMT

We use GroupWise 2014 Resources For Scheduling Our Company Conference and Training Rooms.

We then publish those resource calendars and make them available to our users via the GroupWise Calendar Publishing Host.

The scheduled events show correctly in their respective CST time slots, but when hovering the Mouse over the event, the event time appears in GMT.

For example a CST scheduled event from 12:00 - 1:00PM appears in the popup as 5:00 - 6:00PM or 5 GMT.

The default calendar view on the Calendar Publishing Host is Month, so the user never sees the actual CST Event Time and assumes the GMT displayed. (Not Good!)

Is there a way to fix this discrepancy?

Tags:

  • In article <dkerbaugh.8gxe5z@no-mx.forums.microfocus.com>, Dkerbaugh
    wrote:
    > For example a CST scheduled event from 12:00 - 1:00PM appears in the
    > popup as 5:00 - 6:00PM or 5 GMT.


    Well that isn't what I'm seeing on a 2014R2.2 system, so we need to
    figure out what is out of plumb.

    Lets start with the basics:
    Which build of the GW agents are you running on and on which
    platform/version?
    Is this reproducible when checking with the system that set the
    booking? Are there any cases yet found where it shows correctly?
    Are all the systems involved running on CST? Server, POA, and system
    browsing in.
    Different browsers?


    Andy of
    http://KonecnyConsulting.ca in Toronto
    Knowledge Partner
    http://forums.novell.com/member.php/75037-konecnya
    If you find a post helpful and are logged in the Web interface, please
    show your appreciation by clicking on the star below. Thanks!

  • I have a test environment and a production environment.

    They are both setup with the same platform and versions. The GroupWise Servers and the Calendar Publishing Servers all have identical builds and versions.

    OES 11 SP3
    SuSE 11 SP4
    eDirectory V8.8.8

    All the Test Environment GroupWise Agents run on the test server and all the Production Environment GroupWise Agents run on the Production Server.
    All GroupWise Agents are V14.2.2

    Our PC's and Servers are all configured for Central Standard Time. Our servers and workstations get time from the same NTP source.

    IE 11, FireFox 59.0.3 and Chrome 66.0.3359.139 all display the same results from both the test and production hosts.

    There are no examples where GMT is not reported for the correct CST Time Slot on either the Test Server or the Production Server. I have verified Production Events as far back as early 2016 to display GMT.

    The calhost.js file states the following:

    /***********************************************************************
    * Display calendar information with respect to the user's workstation
    * time/zone instead of GMT as defined in the published calendar ICS file
    **********************************************************************/
    gwwa.calhost.getCalendarFrameSrcURL = function()
    {


    It appears the calendar publishing server is unable to return the workstations time zone setting for some reason.

    Would it be possible to modify the ICS file / files referred to above so that it defaults to CST vs GMT?

    Thanks for your help.
  • I also logged into the KDE Destop and used Firefox to access the Published Calendars directly from the Calendar Publishing Host Server.
    Same results, the event times are correct, but when you move the mouse over the event, it displays the GMT time.
  • On my test server, I removed the Cal Pub rpm.
    I then installed Cal Pub 14.2.1
    The mouse hover over an event was then correct.
    So I removed Cal Pub rpm again and installed Cal Pub 14.2.2
    The mouse hover over an event still correct and not GMT.

    I then followed the same procedures on my Production Server.
    None of that worked? The mouse hover still displays GMT?

    Also, I know its not supported, but I spun up a GW 2018 Cal Pub Host and pointed it back to my production Post Office.
    The event times were correct with a mouse hover over the event.
  • In article <dkerbaugh.8h1elz@no-mx.forums.microfocus.com>, Dkerbaugh
    wrote:
    > I then followed the same procedures on my Production Server.
    > None of that worked? The mouse hover still displays GMT?


    You've done some great leg work and answered some of my questions
    before I could even ask them.
    The fact you got it working on the test system and with another system
    suggests it is that one install that is broken somehow.
    Is there anything in the relevant logs
    /var/opt/novell/groupwise/calhost/logs
    /var/opt/novell/tomcat6/logs
    Perhaps a mass file compare(diff|BeyondCompare\etc..) of files between
    the working test system and the production
    /opt/novell/groupwise/calhost and calsvr

    checking the Tomcat versions might be good as well between the systems.

    If you were in a virtual environment, an option would be to just spin
    up a small vm for the calendar publishing.

    If you can easily do a service request, that might be the fastest, but
    I understand the desire to chase this one down.

    Andy of
    http://KonecnyConsulting.ca in Toronto
    Knowledge Partner
    http://forums.novell.com/member.php/75037-konecnya
    If you find a post helpful and are logged in the Web interface, please
    show your appreciation by clicking on the star below. Thanks!

  • I did speak with a GroupWise Support Engineer who verified there's a bug in the 14.2.2 Code.
    GroupWise 2014 Developer Support Ends June 30, 2018.

    GroupWise 2018 Code renders the timezone's correctly so there's the fix.

    Thanks for your help!