Import Godaddy SSL wildcard certificate to use GW WebAccess

I am looking for simple ways to implement Godaddy wildcard certificate to use Groupwise Webaccess on Groupwise 2014.2.2 running on Oes11sp3.

Kindly assist with helpful ideas

Tags:

  • Thanks for your response laura... but I am afraid it failed to work after following the steps as mentioned in the TID https://www.novell.com/support/kb/doc.php?id=7010584


    It appears that groupwise is handled by tomcat as I notice if I stop rcnovell-tomcat, I do not get the groupwise webaccess page too.
  • On 16.12.2017 14:24, squadri wrote:
    >
    > Thanks for your response laura... but I am afraid it failed to work
    > after following the steps as mentioned in the TID
    > https://www.novell.com/support/kb/doc.php?id=7010584


    Please be a bit more specific. How did it fail? Error messages?

    >
    > It appears that groupwise is handled by tomcat as I notice if I stop
    > rcnovell-tomcat, I do not get the groupwise webaccess page too.


    Webaccess runs in Tomcat, but is delivered outside by Apache. Your
    question really relates exclusively to Apache and has nothing to do with
    groupwise at all. You must make the apache instance use your certificate.

    CU,
    --
    Massimo Rosen
    Micro Focus Knowledge Partner
    No emails please!
    http://www.cfc-it.de
  • Hi

    Tomcat and Apache work hand-in-hand to provide GroupWise WebAccess services. Both have to be running to have WebAccess working.

    I'll see if I can find something further for you. But remember that that the SSL security is not configured/handled by GroupWise, but rather by the web server it's running on. So you could reference any apache/tomcat documentation on implementing certificates. In fact I would be surprised if Godaddy doesn't have such documentation already available.

    Cheers,
  • As Massimo says, this is really just getting SSL to work on Apache. It's not specifically a GW issue, but if we know exactly what's up that would help. Here are the steps I generally take:

    First, go to a terminal window and type:

    a2enmod -l

    You should see something like this:
    authz_host actions alias auth_basic authz_groupfile authn_file authz_user autoindex cgi dir include log_config mime negotiation setenvif status userdir asis imagemap ssl php5 authz_default proxy proxy_ajp
    If you do not see ssl in this list (in our case right in front of php5), type this:
    a2enmod ssl

    You will see a notice that Module ssl installed
    Now, go to /etc/apache2/vhosts.d
    copy vhost-ssl.template to vhost-ssl.conf

    Using your text editor of choice, edit the info as needed in vhost-ssl.conf – for example, make sure the SSL Engine Switch is turn on:

    SSLEngine on

    Next, find the section for the certificate files. It should look like this:

    SSLCertificateFile /etc/ssl/servercerts/servercert.pem
    SSLCertificateKeyFile /etc/ssl/servercerts/serverkey.pem

    In this instance, we are simply using the the default server certificate files to show you how to do this. If you are purchasing trusted certificates from a commercial certificate authority, put the files you receive from them in a location accessible to Apache2 and use those file paths. If your official certificates have an intermediary certificate, you may also need a line like

    SSLCertificateChainFile /etc/apache2/ssl.crt/gd_bundle.crt

    Next run /etc/init.d/apache2 force-reload to enable.
    Troubleshooting:
    check /etc/sysconfig/apache to make sure ssl is in the modules list
  • Hi,

    Here's a good resource/video demonstrating the steps to take: www.youtube.com/watch