Messenger Status switch automatically to offline even though online

Hey Guys,

i've got an strange issue at my Messenger - after a time (time is different - between 5 to 30 minutes, or after windows switch in the lock screen)
my user appears for other users as offline although i'm actually online.
My status in Messenger is also marked Online - when i click on my Status and choose online
again the other users see me as online again but i have to do this a couple of times
a day because the other users call me an tell me that iam currently offline at messenger which i'm not! 

It happens only at my user (what else -  because i'm the admin ) - all other users don't have this issue.

Any ideas to solve it?

Regards,

Tom

Tags:

  •  

    Hi Tom

    You don't say what version and build of Messenger you have installed.

    Question... you say you are "admin". Are you using an account called "admin", or something similar, that has the same name as your GroupWise super admin user?

    I also recommend that in the GroupWise Admin Console you go to your user account, Messenger tab, Status, and do a "restore default settings". After that restart the Messenging agent.

    Cheers,

     

     

  • Hello Laura,

    we all use messenger version 18.0.0 - 28.11.2017.

    at messenger i'm not using the "admin" account to login, i use my real name user for that.
    so the usernames have no similarities.

    i will try out your recommendation  and let you now if the issue was fixed.

    Thanks,

    Tom

  • Hi Laura,

    it seems that my user is now online for the most of the other users in contact list but not for all of them.

    I also noticed that the last 5 users which i add in the i-Manager are in the contact list
    of messenger were marked as *not found".

    I also try now to activate a new user for messenger, but it dont works, so i check the mars Status.

    this is what mars Status says:

     systemctl status gwm-mars@root.service -l
    ● gwm-mars@root.service - GroupWise Messenger Admin Rest Service (MARS)
       Loaded: loaded (/usr/lib/systemd/system/gwm-mars@.service; disabled; vendor preset: disabled)
       Active: inactive (dead)
    Mar 25 22:42:02 srv-****-** mars.sh[24902]: 2020-03-25 22:42:02,450 INFO  AccessArangoDBSingleton getAdminDB [main] MARS DATABASE is CONNECTED --- User
    Mar 25 22:42:06 srv-****-** mars.sh[24902]: 2020-03-25 22:42:06,236 ERROR MarsServer main [main] java.net.BindException: Address already in use
    Mar 25 22:42:06 srv-****-** mars.sh[24902]: 2020-03-25 22:42:06,236 ERROR MarsServer main [main] ***** MARS IS SHUTTING DOWN  *****
    Mar 25 22:43:28 srv-****-** systemd[1]: Starting GroupWise Messenger Admin Rest Service (MARS)...
    Mar 25 22:43:28 srv-****-** echo[25028]: runasuser=root, runasgroup=root, marslogdir=/var/opt/novell/log/messenger/mars
    Mar 25 22:43:28 srv-****-** systemd[1]: Started GroupWise Messenger Admin Rest Service (MARS).
    Mar 25 22:43:30 srv-****-** systemd[1]: Started GroupWise Messenger Admin Rest Service (MARS).
    Mar 25 22:43:31 srv-****-** mars.sh[25129]: 2020-03-25 22:43:31,845 INFO  AccessArangoDBSingleton getAdminDB [main] MARS DATABASE is CONNECTED --- User
    Mar 25 22:43:35 srv-****-** mars.sh[25129]: 2020-03-25 22:43:35,595 ERROR MarsServer main [main] java.net.BindException: Address already in use
    Mar 25 22:43:35 srv-****-** mars.sh[25129]: 2020-03-25 22:43:35,595 ERROR MarsServer main [main] ***** MARS IS SHUTTING DOWN  *****
     
    i cant start mars now - always dead after 1 second
     
    Any ideas?
     
    Greets Tom 
  •  

    Hi,

    What is the output from:  cat /etc/opt/novell/messenger/uid.conf

    That will give you the uid that mars starts with.

    Cheers,

  • Hi Laura,

    Output is: gwmsgr

    Greets,

    Tom

  • Hi,

    Then your systemclt commands are for gwm-mars@gwmsgr.service  not for "root" as you have posted

    cheers,

     

  • Hi Laura,

    thank god that People like you are here...
    ok mars running now correctly, i could also activate the new user for messenger.

    But groupwise dont update the new user in the contact list of messenger,
    the other 5 user are also still marked as *not found* in the contact list.

    Do you know how i can update the contact list?

    Thank you in advance!

    Greets

    Tom

  • Hi Tom,

    You could try running the configuration script again as that forces a sync of the GroupWise information to the Messenger database.

    Cheers,

     

  • Hi Laura,

    ok i try it out in the night today.

    Thank you!

    Greets,

    Tom

  • Hi Laura,
     
    before running the configuration script again i've looked in the groupwise web admin console and found under messenger/messenger service/objects/ldap-server two entry's: entry 1 - the edirectory server and entry 2 - the groupwise server.

    I have also noticed that the ip adress 127.0.0.1 was entered by the groupwise server which i changed now to the correct ip adress - as port there stands 389 at both entries.

    We use also a default policy at messenger - an edit of the contact list by users was not permitted - i've changed that to permitted.

    As next step i restarted the messaging agent thru the web admin console.

    After that two changes i've relogin at messenger and the first thing that messenger told me in a little popup
    was that he found the 5 contacts which he marked in the past as "not found" in the contact list and
    asked me if i want to remove them which i confirmed with yes - he also had update now the 1 new user of edirectory in the contact list.

    Then i added the missed users manually again and now messenger works fine and shows me the correct status of all contacts and the other contacts see now also my user as online permanently.

    However, i don't know what the fault of this story was.

    Maybee the wrong ip adress of the ldap server with the groupwise entry?

    At this point i only want to ask you one question - at the groupwise ldap server entry
    there are no ldap username and no password entered in the fields - is it required?

    Sorry for so many questions but the problem is, that i have took over this server and don't set up by myself.

    Cheers,

    Tom