Graft in lower version

Hi ..

I have a 3rd party LOB application that will only work with GW8 -> GW2012, unfortunately our team have upgraded to GroupWise 2014 and out bespoke application has stopped working.

The question I have is would it be possible to "introduce" a lower version (in this case GW2012) Domain