Groupwise Restore Area

I'm carrying out a GroupWise restore (GW2014SP1HP1, on SLES11.3 boxes)

Initially I anticipated doing it as I would have on Netware, restore data to PO server, create restore area, assign users, etc.
However, when I attempt to create the restore area it will only let me create the area on the domain server. Since our PO's are on separate servers to the domain, this will need some extra config.

I've never had to do it before, but I know you can have the PO restore files remote. I've restored the PO files to the domain server and got them mounted, but from there I've come unstuck.

I've setup NFS server on the domain server, and setup an export directory. I've tested connecting to it from the same server using the NFS client and it does work.

However, when I configure the NFS client on the PO server through YAST when I save the config I just get an 'Unable to mount the NFS entries from /etc/fstab' error.
When I do it verbose from the CLI I get the slightly more useful 'mount.nfs: No such device'.

I'm a bit baffled as 'showmount -e <podomain>' from the PO server lists the export as there ready to be used.
Firewall is disabled on all servers.

The questions:
1) Is this the right method for carrying out a restore when the PO is on a different server to the domain, or have I been over thinking this?
2) Is there some kind of access control I need to configure on the NFS server to allow external clients? as it appears to work when accessing from the same server.
3) Any other troubleshooting I can do before raising it with Novell.

(Apologies, I know this might turn out to be more a SLES question than a GW one)

Thanks in advance
  • Hi,

    Forgive me, but I'm a little confused!

    Are you saying that you are unable to create a restore area on a server that does not host a domain/MTA?

  • Thanks for your reply, it made me go back and recheck before replying again and you can pretty much ignore everything in my first post.

    I think the issues I was having were because I was using my own admin account. Despite being a sysadmin, it was giving me errors that don't happen when logging in with the 'admin' account.

    I've now managed to get to a point where the post office now reports the restore area, rather than <not set>.

    However, when a windows client tries to access it via 'open backup' I get Error 8219 and 'Failed to connect to a remote network resource'.
    I know there are plenty of posts about this error, so I'm sure I'll get to the bottom of it, if there's any pointers you can provide in the mean time it's be much appreciated.

    Thanks again!
  • Hi,

    Glad that you managed to get your restore area setup :)

    Hmmm... 8219 errors! Firstly, does your folder structure conform to 8.3 naming convention? Secondly, what file system rights do the users have?

    Let us know,

  • Yep, all the folders are 8 characters or under, learned that lesson with GroupWise a long time ago.

    Users have no file system rights, which is why I was keen to keep the restore on the originating Post Office, unless there was no other choice...

    As per my previous post I've been tinkering with NFS, but they are Windows 7 clients (and not enterprise or ultimate edition), so this wouldn't be an option.
    I made the choice to go with vanilla SLES rather than OES for the OS, plus we removed the Novell client from machines long ago so NSS is out too.
    I guess that only leaves CIFS/SMS as a reasonable choice.

    I'm probably going to setup a Domain solely for restores, sadly they're needed frequently enough to warrant it. I'll also look into making it a Windows box if I can figure out if you can mount an ext3 volume in Windows.

    In the mean time, I'm going to pursue keeping the restore on the PO for now. Now that I've realised the original issues I was causing for myself,
  • Final update:
    Got it working with the restore back to the original PO server. The trick was to be logged in as admin and not my own sysadmin account, and ignore the 'file browse' button and what it says, just type the path in.

    As I expected I was over thinking it. Just by questioning my post was enough to set me back on the right track, so thanks a lot! :D
  • Hi Little_Crow

    Just glad that you got it working :)