2014R2 GWIA (Linux) Segfaults/Crashes

Hi all,

Wondering if anyone else is experiencing segfaults/crashes with the 2014R2 GWIA?

We've got two GWIA servers dedicated to client access via IMAP/Authenticated SMTP relaying.

I'm seeing the following messages in /var/log/messages:
Mar 2 10:02:06 gwia01 kernel: [21647617.598583] gwia[17689]: segfault at 25 ip 0000000000000025 sp 00007f7abd0bc568 error 14 in gwia[400000 a4000]
Mar 2 13:37:07 gwia01 kernel: [21660511.839104] gwia[13887]: segfault at 25 ip 0000000000000025 sp 00007f9a9d2ff568 error 14 in gwia[400000 a4000]
Mar 2 13:56:21 gwia01 kernel: [21661664.569878] gwia[15253]: segfault at 21 ip 0000000000000021 sp 00007f7b9cf33568 error 14 in gwia[400000 a4000]
Mar 2 13:36:30 gwia02 kernel: [21655807.921259] gwia[29911] general protection ip:7f510b25a55b sp:7f50ffc63570 error:0 in libinetpack.so.1[7f510afd5000 431000]
Mar 2 13:56:27 gwia02 kernel: [21657003.859824] gwia[32021]: segfault at 21 ip 0000000000000021 sp 00007f0847df0568 error 14 in gwia[400000 a4000]

I intend to open an SR for this but am interested to know if anyone else is seeing this as well?

Best wishes,
John.

Tags:

  • jwtaylor,

    It appears that in the past few days you have not received a response to your
    posting. That concerns us, and has triggered this automated reply.

    These forums are peer-to-peer, best effort, volunteer run and that if your issue
    is urgent or not getting a response, you might try one of the following options:

    - Visit http://www.novell.com/support and search the knowledgebase and/or check
    all the other self support options and support programs available.
    - Open a service request: https://www.novell.com/support
    - You could also try posting your message again. Make sure it is posted in the
    correct newsgroup. (http://forums.novell.com)
    - You might consider hiring a local partner to assist you.
    https://www.partnernetprogram.com/partnerfinder/find.html

    Be sure to read the forum FAQ about what to expect in the way of responses:
    http://forums.novell.com/faq.php

    Sometimes this automatic posting will alert someone that can respond.

    If this is a reply to a duplicate posting or otherwise posted in error, please
    ignore and accept our apologies and rest assured we will issue a stern reprimand
    to our posting bot.

    Good luck!

    Your Novell Forums Team
    http://forums.novell.com


  • In article <jwtaylor.7bxoc0@no-mx.forums.microfocus.com>, Jwtaylor
    wrote:
    > Wondering if anyone else is experiencing segfaults/crashes with the
    > 2014R2 GWIA?


    Sorry for the delay, which I think also gives you an answer of how many
    of us are seeing this.
    I haven't seen it myself or heard of others encountering this.
    Good luck with the SR


    Andy of
    http://KonecnyConsulting.ca in Toronto
    Knowledge Partner
    http://forums.novell.com/member.php/75037-konecnya
    If you find a post helpful and are logged in the Web interface, please
    show your appreciation by clicking on the star below. Thanks!

  • Hi John,

    In addition to what Andy has said.... if you do open a SR please give us feedback on how it goes and what the resolution to your issue is.

    Many thanks.

    Cheers,
  • Hi Andy/Laura,

    The GWIA(s) have been behaving for roughly a week now. Will definitely open an SR if they misbehave again. *sighs* GW 2014 R2 has certainly been a real pain for us!


    Cheers,
    John
  • Hi John,
    Just wondering how your GWIA's are behaving? I upgraded our GWIA to 2014r2.2 last week and had a segfault over the weekend.
    Apr 15 23:27:50 GWGATEWAYS kernel: [380502.222802] gwia[2399]: segfault at c0 ip 00007f91dc3420ac sp 00007f91d2380c80 error 4 in libtoolkit.so.1[7f91dc2f9000 bb000]
    This GWIA also performs IMAP servicing.

    We were on GW2012.4, and that was very stable :-(
    Regards
    Kevin

    jwtaylor;2421497 wrote:
    Hi all,

    Wondering if anyone else is experiencing segfaults/crashes with the 2014R2 GWIA?

    We've got two GWIA servers dedicated to client access via IMAP/Authenticated SMTP relaying.

    I'm seeing the following messages in /var/log/messages:
    Mar 2 10:02:06 gwia01 kernel: [21647617.598583] gwia[17689]: segfault at 25 ip 0000000000000025 sp 00007f7abd0bc568 error 14 in gwia[400000 a4000]
    Mar 2 13:37:07 gwia01 kernel: [21660511.839104] gwia[13887]: segfault at 25 ip 0000000000000025 sp 00007f9a9d2ff568 error 14 in gwia[400000 a4000]
    Mar 2 13:56:21 gwia01 kernel: [21661664.569878] gwia[15253]: segfault at 21 ip 0000000000000021 sp 00007f7b9cf33568 error 14 in gwia[400000 a4000]
    Mar 2 13:36:30 gwia02 kernel: [21655807.921259] gwia[29911] general protection ip:7f510b25a55b sp:7f50ffc63570 error:0 in libinetpack.so.1[7f510afd5000 431000]
    Mar 2 13:56:27 gwia02 kernel: [21657003.859824] gwia[32021]: segfault at 21 ip 0000000000000021 sp 00007f0847df0568 error 14 in gwia[400000 a4000]

    I intend to open an SR for this but am interested to know if anyone else is seeing this as well?

    Best wishes,
    John.