GroupWise 2014 Caching client database corruption

Hello everybobody.

I need help with very strange behavior of GroupWise client. I tried to create new Service Request, but that portal gave me an internal error. So until it will be fixed I'm trying to search my luck here.

I have 3 users that keep getting an error messages in their Caching mailboxes.
The message content is: "GroupWise has encountered a problem with your mailbox. GroupWise can rebuild your mailbox to avoid further problems. Rebuild now (this may take several minutes)?".

Users just work with their clients, no matter what they do, period of errors is various, but at least one per day. Error window can or cannot be closed (it's also various, but many times GroupWise client is frozen), so they have to kill grpwise.exe process. CPU and memory usage of "dead" process looks normal (about 0-1% CPU, memory depends on mailbox's size).
At the next start, client rebuilds database and so on. If I try to check caching database manually (gwcheck), everything looks healthy, no errors in log.
Manual deletion (and creation in client again) of Caching database directory makes no change, after that GW client fails with same error messages. And no errors appears in POA log files.

Rebuild times are various (depends on size/number of messages and computer power). First user has fast laptop with SSD and small database, so it's a few seconds job, but second user has about 60k of messages in 8,5GB and rebuild is very slow, so user can't work with his mail during that process.

Everything is ok in Online mode. Online user databases are ok (I made checks in admin console).

I tried to reconfigure our AV (we use Eset Endpoint Antivirus), bud without success, so I also tried to uninstall it, but that was also without impact to GroupWise client bad behaviour. I am 100% sure that there are no running agents manipulating with GW database. HDDs of both computers are also ok, I made some stress tests.

Our systems are standard:
- fully actualized Windows 7 Pro x86 and x64 (Czech)
- client GroupWise 2014 SP1 HP1 (we use Czech locale); servers GW 2014 SP1 (14.0.1)
- profiles are stored in default path (c:\Users\username\AppData\Local\Novell\GroupWise\)

We have 291 users on 2 PO (e.g. 50% use Online, 50% Caching) and only 3 of them have these problems (fourth user had same issue, but only once, so I'm waiting, if it appears again).


Is there any procedure to fix this errors?

Sorry for my English and very long post.
Thanks Jiri

Tags:

  • ulybin wrote:

    >
    > Hello everybobody.
    >
    > I need help with very strange behavior of GroupWise client. I tried to
    > create new Service Request, but that portal gave me an internal error.
    > So until it will be fixed I'm trying to search my luck here.
    >
    > I have 3 users that keep getting an error messages in their Caching
    > mailboxes.
    > The message content is: "GroupWise has encountered a problem with your
    > mailbox. GroupWise can rebuild your mailbox to avoid further problems.
    > Rebuild now (this may take several minutes)?".
    >
    > Users just work with their clients, no matter what they do, period of
    > errors is various, but at least one per day. Error window can or
    > cannot be closed (it's also various, but many times GroupWise client
    > is frozen), so they have to kill grpwise.exe process. CPU and memory
    > usage of "dead" process looks normal (about 0-1% CPU, memory depends
    > on mailbox's size).
    > At the next start, client rebuilds database and so on. If I try to
    > check caching database manually (gwcheck), everything looks healthy,
    > no errors in log.
    > Manual deletion (and creation in client again) of Caching database
    > directory makes no change, after that GW client fails with same error
    > messages. And no errors appears in POA log files.
    >
    > Rebuild times are various (depends on size/number of messages and
    > computer power). First user has fast laptop with SSD and small
    > database, so it's a few seconds job, but second user has about 60k of
    > messages in 8,5GB and rebuild is very slow, so user can't work with
    > his mail during that process.
    >
    > Everything is ok in Online mode. Online user databases are ok (I made
    > checks in admin console).
    >
    > I tried to reconfigure our AV (we use Eset Endpoint Antivirus), bud
    > without success, so I also tried to uninstall it, but that was also
    > without impact to GroupWise client bad behaviour. I am 100% sure that
    > there are no running agents manipulating with GW database. HDDs of
    > both computers are also ok, I made some stress tests.
    >
    > Our systems are standard:
    > - fully actualized Windows 7 Pro x86 and x64 (Czech)
    > - client GroupWise 2014 SP1 HP1 (we use Czech locale); servers GW 2014
    > SP1 (14.0.1)
    > - profiles are stored in default path
    > (c:\Users\username\AppData\Local\Novell\GroupWise\)
    >
    > We have 291 users on 2 PO (e.g. 50% use Online, 50% Caching) and only
    > 3 of them have these problems (fourth user had same issue, but only
    > once, so I'm waiting, if it appears again).
    >
    >
    > Is there any procedure to fix this errors?


    Try running a standalone GWCheck, analyze/fix on structure
  • ulybin wrote:

    >
    > Hello everybobody.
    >
    > I need help with very strange behavior of GroupWise client. I tried to
    > create new Service Request, but that portal gave me an internal error.
    > So until it will be fixed I'm trying to search my luck here.
    >
    > I have 3 users that keep getting an error messages in their Caching
    > mailboxes.
    > The message content is: "GroupWise has encountered a problem with your
    > mailbox. GroupWise can rebuild your mailbox to avoid further problems.
    > Rebuild now (this may take several minutes)?".
    >
    > Users just work with their clients, no matter what they do, period of
    > errors is various, but at least one per day. Error window can or
    > cannot be closed (it's also various, but many times GroupWise client
    > is frozen), so they have to kill grpwise.exe process. CPU and memory
    > usage of "dead" process looks normal (about 0-1% CPU, memory depends
    > on mailbox's size).
    > At the next start, client rebuilds database and so on. If I try to
    > check caching database manually (gwcheck), everything looks healthy,
    > no errors in log.
    > Manual deletion (and creation in client again) of Caching database
    > directory makes no change, after that GW client fails with same error
    > messages. And no errors appears in POA log files.
    >
    > Rebuild times are various (depends on size/number of messages and
    > computer power). First user has fast laptop with SSD and small
    > database, so it's a few seconds job, but second user has about 60k of
    > messages in 8,5GB and rebuild is very slow, so user can't work with
    > his mail during that process.
    >
    > Everything is ok in Online mode. Online user databases are ok (I made
    > checks in admin console).
    >
    > I tried to reconfigure our AV (we use Eset Endpoint Antivirus), bud
    > without success, so I also tried to uninstall it, but that was also
    > without impact to GroupWise client bad behaviour. I am 100% sure that
    > there are no running agents manipulating with GW database. HDDs of
    > both computers are also ok, I made some stress tests.
    >
    > Our systems are standard:
    > - fully actualized Windows 7 Pro x86 and x64 (Czech)
    > - client GroupWise 2014 SP1 HP1 (we use Czech locale); servers GW 2014
    > SP1 (14.0.1)
    > - profiles are stored in default path
    > (c:\Users\username\AppData\Local\Novell\GroupWise\)
    >
    > We have 291 users on 2 PO (e.g. 50% use Online, 50% Caching) and only
    > 3 of them have these problems (fourth user had same issue, but only
    > once, so I'm waiting, if it appears again).
    >
    >
    > Is there any procedure to fix this errors?


    Try running a standalone GWCheck, analyze/fix on structure
  • ulybin wrote:

    >
    > Hello everybobody.
    >
    > I need help with very strange behavior of GroupWise client. I tried to
    > create new Service Request, but that portal gave me an internal error.
    > So until it will be fixed I'm trying to search my luck here.
    >
    > I have 3 users that keep getting an error messages in their Caching
    > mailboxes.
    > The message content is: "GroupWise has encountered a problem with your
    > mailbox. GroupWise can rebuild your mailbox to avoid further problems.
    > Rebuild now (this may take several minutes)?".
    >
    > Users just work with their clients, no matter what they do, period of
    > errors is various, but at least one per day. Error window can or
    > cannot be closed (it's also various, but many times GroupWise client
    > is frozen), so they have to kill grpwise.exe process. CPU and memory
    > usage of "dead" process looks normal (about 0-1% CPU, memory depends
    > on mailbox's size).
    > At the next start, client rebuilds database and so on. If I try to
    > check caching database manually (gwcheck), everything looks healthy,
    > no errors in log.
    > Manual deletion (and creation in client again) of Caching database
    > directory makes no change, after that GW client fails with same error
    > messages. And no errors appears in POA log files.
    >
    > Rebuild times are various (depends on size/number of messages and
    > computer power). First user has fast laptop with SSD and small
    > database, so it's a few seconds job, but second user has about 60k of
    > messages in 8,5GB and rebuild is very slow, so user can't work with
    > his mail during that process.
    >
    > Everything is ok in Online mode. Online user databases are ok (I made
    > checks in admin console).
    >
    > I tried to reconfigure our AV (we use Eset Endpoint Antivirus), bud
    > without success, so I also tried to uninstall it, but that was also
    > without impact to GroupWise client bad behaviour. I am 100% sure that
    > there are no running agents manipulating with GW database. HDDs of
    > both computers are also ok, I made some stress tests.
    >
    > Our systems are standard:
    > - fully actualized Windows 7 Pro x86 and x64 (Czech)
    > - client GroupWise 2014 SP1 HP1 (we use Czech locale); servers GW 2014
    > SP1 (14.0.1)
    > - profiles are stored in default path
    > (c:\Users\username\AppData\Local\Novell\GroupWise\)
    >
    > We have 291 users on 2 PO (e.g. 50% use Online, 50% Caching) and only
    > 3 of them have these problems (fourth user had same issue, but only
    > once, so I'm waiting, if it appears again).
    >
    >
    > Is there any procedure to fix this errors?


    Try running a standalone GWCheck, analyze/fix on structure
  • Thanks for reply.
    I made standalone GWCheck many times with same result: no errors or problems.
    No it's look like we are affected by bug you mentioned.

    I finally made new SR, so now I'm waiting for an answer.
  • Hi

    Further to what has already been suggested, ensure that the local "Cache" directory and sub-structure are excluded from AV software. I've found tremendous problems with this in the past! For what it's worth.

    Cheers,
  • Helllo,
    I tried it with and also without excluding "Cache" directory from AV, but it didn't helped.

    I made SR in Win 7 and IE (Support page issued some Internal errors with my Firefox on Fedora) and wise lady from support sent me link to Novell's ftp with non public build (119031) of GroupWise Client. I installed it to all my problematic users (6 at this time). They have no caching error after install of 119031 build. jmarton was right.

    Thank you all;)
  • Hi,

    Thank you for the feedback - so glad that your issues are sorted out.

    Cheers,
  • Hi there!, how are you?, First of all, THANKS for sharing this issue and workaround!. I'm having the same issue but with GW2018.2.1. 

    I will open a SR reporting the issue and also give as reference this discussion. 

    Best regards.,