GroupWise 2014 R2 Support Pack 2 (14.2.2) released

http://download.novell.com/Download?buildid=FpCD1GJ8vgg~

Micro Focus has released GroupWise 2014 R2 Support Pack 2 (14.2.2)

Security Fixes
1022895 - Oracle Outside-In security updates for Jan 2017
1020674 - JRE update

Change Log

Admin
967687 - Sort Exclude lists in GWIA Access Control and POA Scheduled Events
973362 - Unsuccessful LDAP sync by MTA sets on user accounts expiration date
980717 - After upgrade to 2014, not able to remove gateway alias from external entities
986015 - Issue with password expiration policy and Active Directory
1021769 - Domain administrator cannot edit users in GW Admin console if domain/po name is in the incorrect case (uppercase or lowercase)
1025098 - Reorder the items on the Client Options Integration left-hand navigation panel
1030315 - The GroupWise Administration Console displays an error when working with nicknames for resource objects
1030950 - Help link errors
1031552 - Fix problems with validating roles for mixed case domains and post offices

Calendar Server
1000912 - All day events without timezone show up on wrong day

Calendar Publisher
982841 - Published calendars do not display in Firefox or IE with compatibility mode

Windows Client
1018927 - Infinite loop when accepting an appointment that has a view name or account id (comes in from outside the system)
987250 - Client hangs when trying to access attachments in shared folders
989822 - Drag and drop attachment to desktop changes the "name information" of the file
996425 - GW client always downloads a mail attachment / BLOB via a secure C/S connection
1000763 - Attachment jpg lost when forwarding message
1005656 - PTX document temp files are removed with application still open
963384 - AM/PM mark drawing incorrectly
981506 - Appointment sent from custom view shows 1.1.1970.
1009712 - Day picker window overlap issue when calendar view is maximized on entire screen.
1012606 - The Month and Calendar view does not update when switching back and forth to a proxy mailbox.
1012686 - Client locking up when clicking on the calendar tab.
972176 - Skype ics not showing all text in description.
998407 - Sort by Categories does not also sort by date.
963816 - Copy and paste from HTML view still adding unwanted spaces.
1009726 - Copying and pasting an image from one mail to another fails.
990858 - Delegate does not work anymore after upgrade to 14.2.x POA.
982898 - Unread panel suddenly turns on sent items.
994003 - Filtering the sent items folder, when sorted by subject, never returns anything.
986065 - Find / Filter in a Remote /Caching Mailbox is showing too many results.
994318 - Quicksearch only finds items of today.
1016906 - Quicksearch not showing calendar items.
968473 - D126 record update filter failed error when searching a shared folder.
989066 - Shared sub-calendars are missing the calendarAttribute element.
965851 - Blank line added in message body.
984991 - Hyperlink issues when attachment filename contains cyrillic characters.
987962 - HTML message body text disappears when GW user clicks on Reply.
996948 - Default encoding does not properly display message.
1002545 - Mail body is blank.
1005490 - Client crash on mso99Lwin32client.dll / mso20win32client.dll.
1007237 - maito puts html in message body.
1015820 - Some 14.2.2 FTF builds are not working correctly with Formativ portal.
1017947 - GroupWise client does not properly display received HTML message.
938962 - Client install error "ordinal not found".
988367 - Install.bat /unattended error - Microsoft Visual C 2013.
989114 - Client install breaks iPrint client - MSVCR120.dll.
990018 - Unattended GroupWise Client 2014 R2 SP1 via Zen is no longer working.
1015438 - Running install.bat with silent, errors out the first time.
957875 - Words improperly marked as mispelled when switching languages.
962780 - Unexpected mail group selection after previewing few mails.
985899 - Client crash while sending mail or replying to mail.
988318 - New mail flag on shared folder shows every time the client is started regardless of whether there is new mail or not.
990955 - Since upgrading to R2 SP1, the client hangs when opening random email messages.
991072 - C006 error in German client.
991522 - Original message with Chinese characters get garbled when using forward using GW client.
993380 - Client crashes at times when opening, forwarding or replying to messages.
981449 - Client crashes in caching mode.
982271 - Link on email does not link to the correct page.
984644 - Running R2HP1, users get D04F several times throughout the day.
987065 - D04F error at random times while running the windows client.
989636 - Random client crashes with the R2 SP1 client - Folder Tree related.
990512 - Client crash on Windows 10 since upgrade to r2 sp1.
991310 - GroupWise client hangs when opening certain messages.
1009131 - Client crashes randomly.
1015353 - Application connection table full after upgrade into HP2 and using newer clients.
1020155 - Client takes 40 to 50 seconds longer to do anything after moving system from Linux to Windows.
986599 - Inconsistent color use.
992586 - Changing from filtered mailbox to filtered multi user calendar view hangs client.
975407 - Printing message in Chinese prints the signature line even if there is no signature there.
959989 - Sending a mail from a proxy mailbox to a personal group has 0 recipients.
994029 - Sender address set in new format GHV templates not being used when sending messages via proxied user.
990954 - When doing a reply to all on a message from an appliance, the To field is blank.
999695 - Part of the message is missing when using reply.
1008562 - Client crashes when replying/forwarding an email with image.
1013138 - For messages from the email address of a distribution list, replies go to recipient rather than to distribution list email address.
946177 - Colon missing in 'when actions are' section after Accept Rule has been created.
1022338 - NGW_E_UDW_RULE_TOKEN_FLAGS is not written to the database if there is not a start and end date set (Needed for Mobility to function as expected).
1024755 - Client crash with vacation rule.
1026226 - Vacation Rule: If the Main message body is empty, the External message body can't be saved.
992737 - Unable to save an attachment from a forwarded mail.
1024219 - Users can send emails despite mailbox showing that quota has been exceeded.
988832 - Caching client does not use Default Global Signature.
979365 - Task list panels display "Start Date" for posted tasks as "Today" rather than actual start dates.
909061 - Unable to save default compose font color settings.
995585 - Backslash in saved view changes to ampersand.
1000089 - Saving modified customer view corrupts file.
1005250 - Client crash selecting December 1 or 2 in MU view.
984925 - Groupwise sees pdf files created with pdf creator version 1.6 as something other than text.
1001144 - Hang when opening mail.
1031126 - Cursor positioned incorrectly after createing second bullet point formatting section.

Document Viewer Agent
970685 - DVA cores even after applying gw14.2.0-122791.
983966 - DVA goes into high utilization several times during the day - waiting Oracle Stellent fixes.
1018418 - DVA is creating tons of files - randomly resulting in disk full errors.
1025991 - GroupWise DVA Seg faults immediately on startup.

Engine
981424 - GWIA can't look up name servers in Windows 2012 R2 if server is setup as a DHCP.
986301 - Status tracking on completed checklist items.
986325 - Duplicate cancel notifications on appointments from Exchange.
986330 - Duplicate appointments after an appointment update from Exchange.
987392 - Auto-replies display string "
  • In article <bkesting.7wnagn@no-mx.forums.microfocus.com>, Bkesting
    wrote:
    > 983966 - DVA goes into high utilization several times during the day -
    > waiting Oracle Stellent fixes.


    Ahhh, that will be nice, as even though the utilization was niced, it
    sets off NAGios at times.



    Andy of
    http://KonecnyConsulting.ca in Toronto
    Knowledge Partner, trying to stop Mr Automatic from complaining.
    http://forums.novell.com/member.php/75037-konecnya
    If you find a post helpful and are logged in the Web interface, please
    show your appreciation by clicking on the star below. Thanks!

  • Additionally:

    What's New in GroupWise 2014 R2 SP2

    - Micro Focus Filr Integration: GroupWise 14.2.2 allows you to integrate with Micro Focus Filr. You can enable Filr in the Admin Console > select a Domain, PO or user > Client Options > Integrations > Micro Focus Filr. You will need to enter the URL of your Filr installation. With Filr enabled, you can force all attachments to be placed in Filr or set a size limit for the attachments and anything over that size is placed in Filr. In the client, when creating an email, you can add a Filr reference as an attachment or upload an attachment to Filr when you send the email. You can search Filr when using Find. You can save received attachments to Filr using the File > Save menu.

    - DE Mail Integration: You can enable DE Mail in the Admin console > select a Domain, PO or user > Client Options > Integrations > DE Mail. Users will then see DE Mail options in the client when sending an email to a DE Mail address.

    - Vacation Rule Enhancements: Vacation rules have been updated so that you can have a separate message body for replying to external users and you can limit your replies to external Address Book members.

    =====================================

    Known Issues in GroupWise 2014 R2 SP2

    Installing .NET 4.5 on Windows 7 through GroupWise Client takes a long time
    When installing .NET 4.5 on a Windows 7 machine using the GroupWise Client install, the install can take over 12 minutes to install .NET. Installing .NET prior to the GroupWise client install fixes the issue.

    No Default Email Client error after installing GW Client with Microsoft Outlook installed
    If you install the GroupWise Client with Microsoft Outlook installed on the machine, you could run into the following error:

    No e-mail program is assigned to export the desired action. Install a corresponding e-mail program, or create a map in the system control under "Standard Programs" if a program is already installed.

    To fix this issue, create a Novell GroupWise profile in Outlook. See "Creating the GroupWise Account Manually" in the "GroupWise Mobility Service 2014 R2 Administration Guide"

    WebAccess Item Read Window Closes when Navigating to Next or Previous Item
    If you have an item open in WebAccess in Internet Explorer 11 or Microsoft Edge, and you navigate to the next or previous item using the arrows in the Item Read window, then the Item Read window closes. This does not happen in other browsers. We are working on a fix for this issue.

    ===========================================
  • I'm sure this has been asked (and answered) before but.... can the 14.2.2 client access a 14.2.1 PO?
  • Hi CB,

    Yes it can.... it is only between major updates that it can't. Support Packs are inter-operable.

    Cheers,
  • Am 12.04.2017 um 18:46 schrieb cbristol:
    >
    > I'm sure this has been asked (and answered) before but.... can the
    > 14.2.2 client access a 14.2.1 PO?
    >
    >

    In addition to Lauras answer: Of course, any enhancement that needs
    server side features won't work until the server is updated.

    CU,
    --
    Massimo Rosen
    Micro Focus Knowledge Partner
    No emails please!
    http://www.cfc-it.de
  • We found our first problem. The install process for the client, specifically the install.bat that's described for installing with ZCM. It calls for forcing the install of dotnetfx45. This breaks if the computer has the same or newer version already installed. We've tried it a number of different ways, always the same outcome. It should test to see if the dotnetfx45 is already installed and error gracefully. Instead the installer stops to inform the user of the problem. Not so great when it's a silent install or deployed as part of an image.
  • I installed 14.2.2 tonight. Seems to have went smoothly. One thing I did notice, when I run "rpm -qa | grep groupwise" I get:

    groupwise-webaccess-webapp-14.2.2-126868

    When I log into WebAccess and go to Settings > About it shows "Program Release: 14.2.1 11/22/2016 (WebAccsesServlet.class) | POA Version 14.2.2 | POA Build: 126868

    Is it just a cosmetic thing within WebAccess or did I miss something in the upgrade?
  • Browser cache by chance?
    The install bounces tomcat and apache, so these shouldn't be an issue.
  • mathiasbraun;2454894 wrote:
    Browser cache by chance?
    The install bounces tomcat and apache, so these shouldn't be an issue.


    Cache is cleared. Still shows 14.2.1
  • Am 13.04.2017 um 02:06 schrieb raronson:
    >
    > We found our first problem. The install process for the client,
    > specifically the install.bat that's described for installing with ZCM.


    Sorry to say, but please don't use the .bat. It's basically a very bad
    idea to boot to have ZCM call batch files (it has no control over, aka
    can't properly decide if the install worked or not) to install software.
    And then, the .bat isn't really very well done or smart.

    CU,
    --
    Massimo Rosen
    Micro Focus Knowledge Partner
    No emails please!
    http://www.cfc-it.de