gwha file not found during upgrade


I have been running GW14.2.0 (on SLES11SP3/ OES11SP2) and am in the process of applying HP1. After downloading the update and extracting and running ./ on all my servers they all upgrade perfectly.

EXCEPT for 1 server ( The webaccess / GWIA server) running on SLES11SP1. When the installation of the server starts it stops all the agents and then comes up with the error "'novell-groupwise-gwha=o:14.2.0-123047' not found" then ends the installation.

I have checked to see if the patch was corrupt and done the extract again with the same error.I have also done a "find -name" for that file on a working server and this server and it is consistent.

Please help.
  • I have managed to get around this by going to the server directory in the patch software and run an rpm -Uhf on all the rpms I needed.

    Probably something on my SLES that is an issue as it will not even do SLES updates. Next step is to do an upgrade to SLES11SP3 later on. Or wait until I am happy that it will work with SLES12 and rebuild the whole server.
  • Hi,

    Perhaps take a look at this TID:

    Whilst not directly related to the issue you describe, it might point to an issue with your GWHA file.

  • My guess is that you are indeed having trouble with the SLES server. While GW 2014 R2 "might" be okay on SLES11SP1, I've never tried on lower than SP2. Since there really isn't any "config" that you need to do for the server install, your manual update was good. However, WebAccess probably needs an "configured" - but since WebAccess has no dependencies on the GW Server files, I suspect it would run fine.
  • I've seen this, and couldn't find anything related to GroupWise that was causing this problem. Just based on my testing it does seem to be a SLES or zypper cache / repo issue.

    Like you already mentioned, the current workaround to this is a manual update of the RPMs, (rpm -Uvh <rpm name>) in the server/.. directory.

    After you upgrade but still see (2014) or (2012) in the admin overview.. depending which version you previously upgraded from. You'll want to manually copy the .dc files to the domain(s)
    The .dc files can be found in the admin/data directory (/opt/novell/groupwise/admin/data/ on linux)

    If you need to upgrade the database, run these commands after you copy the .dc files to the domain(s):
    gwadminutil upgrade <domain directory>
    gwadminutil upgrade <post office directory>