Published Calendar Recurring Appointment Issue

We are rolling out the ability to publish calendars. I believe we have everything installed correctly and it appears to be working, expect for recurring appointments. In our testing, if a recurring appointment is set to happen on 3 dates, it will show 3 times on each of those 3 days on the web published calendar. It appears correctly on both the GroupWise client and GroupWise webaccess. It the appointment is set to happen on 12 dates, it will show 12 times on each of those 12 days. Is there a way to fix this?
  • In article <strewz.7s4lio@no-mx.forums.microfocus.com>, Strewz wrote:
    > if a recurring appointment is
    > set to happen on 3 dates, it will show 3 times on each of those 3 days
    > on the web published calendar. It appears correctly on both the
    > GroupWise client and GroupWise webaccess. It the appointment is set to
    > happen on 12 dates, it will show 12 times on each of those 12 days. Is
    > there a way to fix this?


    I haven't been able to reproduce this yet.
    So lets run down some basics

    What exact version/build of GroupWise are you running on which platform
    so that we can better guide you.
    Which clients have you used to create the Appointments/Posted
    Appointments? WebAccess vs different regular clients.

    Run through an example of a appointment that reproduces this, so that we
    can better try to see what is happening. Please include which views you
    are seeing this in, i.e. Is it just in the month view or all three?


    Andy of
    http://KonecnyConsulting.ca in Toronto
    Knowledge Partner
    http://forums.novell.com/member.php/75037-konecnya
    If you find a post helpful and are logged in the Web interface, please
    show your appreciation by clicking on the star below. Thanks!

  • Andy,
    Thanks for replying.
    We are running 2014 R2, 14.2.0, build 122092, 12/3/2015, on Windows Server 2012 R2.
    We have a mixture of clients deployed. Mostly 2012 and 2014R2.
    In all cases, these are calendars attached to resources.

    The more I look into it and look at various calendars, this is what I am seeing:
    Appointment scheduled for every Sunday in 2017 (52 days), using 2014R2 client. Looks fine in the client. Looking at it from via the published calendar, it show up twice on every Sunday.
    Appointment scheduled for 10 times, using 2012 client. Looks fine in the client. Looking at it via the published calendar, it show up 10 times on each of the 10 days.
    Appointment scheduled for 22 times, using 2012 client. Looks fine in the client. Looking at it via the published calendar, it show up 22 times on each of the 22 days.
    I tested a new appointment - scheduled for 12 times, using 2014R2 client. Looks fine in the client and on the published calendar.

    The 2014R2 client seems to be better than the 2012 client. I am going to run GWCheck against these resources and I'll update here.
  • Analyze/Fix did not affect anything. Structural rebuild did not affect anything.
  • In article <strewz.7s5z21@no-mx.forums.microfocus.com>, Strewz wrote:
    > We are running 2014 R2, 14.2.0, build 122092, 12/3/2015,


    Very much worth updating at least the back ends for this. We are
    already at SP1 having been updated twice with hotpatchs (one install of
    SPHP2 to get you up to date) with all kinds of fixes in there including
    calendar bits.

    I don't have a resource with a published calendar to play with at the
    moment, all my tests have been with a regular account. It would be
    interesting to compare a resource vs a regular account appointment,
    both being created from the same account client.

    Regular GWChecks help keeps such odd problems to low numbers and makes
    it easier to trouble shoot. Make sure you look at the results to see
    what problems and/or errors are showing and make sure they are dealt
    with.


    Andy of
    http://KonecnyConsulting.ca in Toronto
    Knowledge Partner
    http://forums.novell.com/member.php/75037-konecnya
    If you find a post helpful and are logged in the Web interface, please
    show your appreciation by clicking on the star below. Thanks!

  • In article <strewz.7s60wo@no-mx.forums.microfocus.com>, Strewz wrote:
    > Analyze/Fix did not affect anything. Structural rebuild did not affect
    > anything.


    Contents?
    If you running scheduled GWChecks, this was not surprising
    http://www.konecnyad.ca/andyk/gwmnt5x.htm


    Andy of
    http://KonecnyConsulting.ca in Toronto
    Knowledge Partner
    http://forums.novell.com/member.php/75037-konecnya
    If you find a post helpful and are logged in the Web interface, please
    show your appreciation by clicking on the star below. Thanks!