Attaching file with virtualized browser deletes text

Totally weird one. We have sales people who travel about and do a lot of searching on the web, so they tend to use a virtualized web browser (Comodo Dragon), and empty the "sandbox" when they are done (that way if any "gifts" were deposited on their system from the web surfing they are held in a virtual box and get deleted when the sandbox is emptied). If they are in web access for e-mail, and reply to a message and then attach a file, it ends up deleting 1 or more characters from the start of their reply. So if they start a message with "Hi Val," then click on the attach tab and attach a file, when they go back into the Mail tab the reply reads "i Val," or sometimes " Val". And if they add more attachments, it deletes more text each time. Interestingly enough, this also does happen in a non-virtualized Dragon browser. It does not happen with Firefox used normally or virtualized. Does not seem to make a difference whether the settings are plain view and plain compose, html view and html compose, or any other combination. The only thing I can come up with is the cursor is focused on the first line of the reply in Firefox, and it is not in Comodo Dragon. I am not entirely sure why that would make any difference. I even tried putting in a hard return first before typing a reply and then adding an attachment, and it just deletes the hard return and the first character in the reply text. If have tried with .txt, .csv. .doc, .chm, .pdf. .xls .rtf attachments, and there is no difference, effect is the same.

Anyone ever seen this issue before? Totally strange.