Sync errors with Windows 8 phones.

Has anyone been having issues with syncing Windows 8 devices? We have about 50 HTC 8X phones and around 10% of them are having sporadic sync errors. We also have some of the Nokia WP8 devices that exhibit the same issues. While the WP8 device is problematic, we can have an Android or iOS device working next to it just fine. The error on the device is 85002012. Would be interested to see if this is consistent among users of GMS2, or is there something wrong with us. I did open an SR with support and I can report back any findings from there.
  • In our test environment we had problems with wp8, the certificate and the mobility server addresses didnt match, androids didnt have problem with that, wp8 didnt work. Generated a new self-signed certificate with correct name and put that to use and wp8 started to sync.
    https://www.novell.com/support/kb/doc.php?id=7007674
    In the end just restart gms service, instead of old datasync.
  • we are having the same problems, I have around 400 iOS device 4 android and 3 nokia WP8 phone. all where working fine on datasync 1.2.xxx since upgrading datasync to ver 2.x . had all sort of troble with the Nokia WP8 phone., they will run fine for a few days, then syning stops, or address book get corupted . i use even received some contacts from another WP8 address book.. very stange.
  • In article <stevecim.6bttfb@no-mx.forums.novell.com>, Stevecim wrote:
    > we are having the same problems, I have around 400 iOS device 4 android
    > and 3 nokia WP8 phone. all where working fine on datasync 1.2.xxx since
    > upgrading datasync to ver 2.x . had all sort of troble with the Nokia
    > WP8 phone., they will run fine for a few days, then syning stops, or
    > address book get corupted . i use even received some contacts from
    > another WP8 address book.. very stange.


    Check your cert, make sure there aren't any issues with it. Is is self
    signed or a purchased one?
    Otherwise this sounds like it would be worth opening an SR


    Andy of
    KonecnyConsulting.ca in Toronto
    Knowledge Partner
    http://forums.novell.com/member.php/75037-konecnya
    If you find a post helpful and are logged in the Web interface, please
    show your appreciation by clicking on the star below. Thanks!

  • I had to re-init the users and set the phones to timed pulls instead of push...
    Don't think its a cert issue, becuase every thing was working fine in ver 1.2.xxx and it's fronted by a reverse proxy.
    the 400 odd iphone/ipads we have are working fine.. Only the win8 phone have started playing up with the upgrade.
  • In article <stevecim.6ccgq0@no-mx.forums.novell.com>, Stevecim wrote:
    > Don't think its a cert issue...


    We can't rule it out and the Window8 systems have demonstrated
    themselves to be particularly picky about certs. It could well be that
    something else happened to change in the same time you upgraded that is
    confusing the issue (always frustrating when that happens). Check your
    certs to be sure is how we rule them out and the Heartbleed issue has
    brought lots of such tools out. One I've been using that may help you
    is
    https://sslanalyzer.comodoca.com/

    Are you actually using the same cert you were running before? Just in
    case the upgrade replaced your cert.


    Andy of
    KonecnyConsulting.ca in Toronto
    Knowledge Partner
    http://forums.novell.com/member.php/75037-konecnya
    If you find a post helpful and are logged in the Web interface, please
    show your appreciation by clicking on the star below. Thanks!

  • In article <stevecim.6ccgq0@no-mx.forums.novell.com>, Stevecim wrote:
    > Don't think its a cert issue...


    We can't rule it out and the Window8 systems have demonstrated
    themselves to be particularly picky about certs. It could well be that
    something else happened to change in the same time you upgraded that is
    confusing the issue (always frustrating when that happens). Check your
    certs to be sure is how we rule them out and the Heartbleed issue has
    brought lots of such tools out. One I've been using that may help you
    is
    https://sslanalyzer.comodoca.com/

    Are you actually using the same cert you were running before? Just in
    case the upgrade replaced your cert.


    Andy of
    KonecnyConsulting.ca in Toronto
    Knowledge Partner
    http://forums.novell.com/member.php/75037-konecnya
    If you find a post helpful and are logged in the Web interface, please
    show your appreciation by clicking on the star below. Thanks!