Caching-mode client hangs onto outdated/nonexistent global signature

Well, here's a crummy situation: One of my telecommuters realized today
that an outdated global signature was being applied to her messages (we
only attach them to external mail, so no one in the office caught it).
So I updated her client and ran gwcheck (analyze/fix everything) on her
live and caching mailboxes.

The outdated global signature remains.

If I use a different machine, the correct global signature is appended.

Later today, when I can get access to her computer again, I will see
what happens if I use that machine, but switch the GW client to online mode.

But if the global signature is appended at the gwia, how can it matter
what client or machine the message originates from?

And how can I get this particular machine to pick up the current signature?

Of course this is one of the irascible users who will be very happy to
judge harshly and loudly if I can't fix this quickly.

Tags:

Parents
  • On 12/17/2015 1:41 PM, Mary Wood wrote:
    > Well, here's a crummy situation: One of my telecommuters realized today
    > that an outdated global signature was being applied to her messages (we
    > only attach them to external mail, so no one in the office caught it).
    > So I updated her client and ran gwcheck (analyze/fix everything) on her
    > live and caching mailboxes.
    >
    > The outdated global signature remains.
    >
    > If I use a different machine, the correct global signature is appended.
    >
    > Later today, when I can get access to her computer again, I will see
    > what happens if I use that machine, but switch the GW client to online
    > mode.
    >
    > But if the global signature is appended at the gwia, how can it matter
    > what client or machine the message originates from?
    >
    > And how can I get this particular machine to pick up the current signature?
    >
    > Of course this is one of the irascible users who will be very happy to
    > judge harshly and loudly if I can't fix this quickly.



    Update: Going from caching to online and back to caching helped - but
    still doesn't make sense. And for those who always work in caching
    mode, it's not good to have this get stuck, if your company policy is to
    change global signatures from time to time.
  • In article <EmFcy.988$ct1.845@novprvlin0913.provo.novell.com>, Mary Wood
    wrote:
    > And for those who always work in caching
    > mode, it's not good to have this get stuck, if your company policy is to
    > change global signatures from time to time.


    How long had the change been in place? There are supposed to be sync
    processes that would eventually get it. I can see it being a part of the
    "Refresh address books and rules every" X "days" that defaults to 7 under:
    Accounts, Account Options, properties of the account, Advanced tab, bottom.


    Andy of
    http://KonecnyConsulting.ca in Toronto
    Knowledge Partner
    http://forums.novell.com/member.php/75037-konecnya
    If you find a post helpful and are logged in the Web interface, please show
    your appreciation by clicking on the star below. Thanks!

  • In article <laurabuckley.788ja0@no-mx.forums.microfocus.com>, Laurabuckley
    wrote:
    > After not doing anything to fix this issue it has auto-magically
    > resolved itself overnight. There has been a period of four days between
    > editing the signature and the correct one being applied to mail being
    > sent out from a Caching mailbox.


    Well if your "Refresh address books and rules every" is set to 1 "days",
    this it isn't that one. Hmm, where else is there such a refresh cycle?
    Might be more of an issue that it is one we don't have access to change.
    I am assuming you've now set a new sig today to see when it next flows
    down. My bet is Tuesday next week.


    Andy of
    http://KonecnyConsulting.ca in Toronto
    Knowledge Partner
    http://forums.novell.com/member.php/75037-konecnya
    If you find a post helpful and are logged in the Web interface, please
    show your appreciation by clicking on the star below. Thanks!

  • Hi Andy,

    I've reported this, in the backrooms, to Novell. I'll post back any feedback I get so please watch this space :)

    Cheers,
  • On 12/22/2015 12:56 AM, laurabuckley wrote:
    >
    > Hi Andy,
    >
    > I've reported this, in the backrooms, to Novell. I'll post back any
    > feedback I get so please watch this space :)
    >
    > Cheers,
    >
    >

    Watching carefully, since we have a global sig that should change over
    in 3...2....1... and didn't.
  • Hi Mary,

    Unfortunately due to the time of year with most people [engineering and otherwise] being on holiday this will only receive attention in the new year. I have no suggestions in the interim to resolve this issue as I've tried absolutely everything I can think of.

    So, please continue to watch this space ;)

    Cheers,
  • I have found mention of this bug as far back as GW 7! It makes me mad
    that it's still not fixed. I'm guessing they have no intention of
    fixing it.



    On 12/30/2015 11:16 PM, laurabuckley wrote:
    >
    > Hi Mary,
    >
    > Unfortunately due to the time of year with most people [engineering and
    > otherwise] being on holiday this will only receive attention in the new
    > year. I have no suggestions in the interim to resolve this issue as
    > I've tried absolutely everything I can think of.
    >
    > So, please continue to watch this space ;)
    >
    > Cheers,
    >
    >


  • Hi Mary,

    Whilst I have reported this in the backrooms to the folk at Novell, you may want to open a Service Request to get more immediate assistance.

    Here's what I have done to try resolve this issue, just for your reference:

    I update/amend my existing Global Signature and restart the POA for good measure. Instantly any e-mail sent from an Online mailbox has the new Global Signature. Now here's the problem.... any e-mail sent in Caching mode still uses the outdated/old Global Signature.

    Steps to try correct the problem:

    Send/Receive
    Retrieve Contacts
    Switch to online mode and back to Caching mode
    Update Address books set to 1 day
    GWCheck | analyse/Fix | Contents | User database (from Admin Console)
    Retrieve Entire Mailbox
    Tools | Repair Mailbox | Analyse/Fix | Contents | User database (inside Caching Mailbox)

    None of the above updated the Global Signature on my Caching mailbox.

    Further testing:

    On POA set Global Signature to NONE and restart POA. E-mail sent from both Online and Caching mailbox has no Global Signature attached. On POA set Global Signature back to the one that was amended and restart POA. Caching mailbox still sends e-mail with outdated/old Global Signature.
    Scheduled maintenance has been running as per schedule on POA both Structure check each night and a full Content check on Friday night. This made no difference.

    Now here's the really weird thing, after approximately four days (give or take an hour or two) the Global Signature on the Caching mailbox updated.

    Rinse
  • I have an SR for you!
    10987536801

    I've seen it suggested that the R2 client may not have this issue, but I
    see that folks are asking about other problems they're finding with it -
    and I don't need those.



    On 1/6/2016 11:16 PM, laurabuckley wrote:
    >
    > Hi Mary,
    >
    > Whilst I have reported this in the backrooms to the folk at Novell, you
    > may want to open a Service Request to get more immediate assistance.
    >
    > Here's what I have done to try resolve this issue, just for your
    > reference:
    >
    >> I update/amend my existing Global Signature and restart the POA for good
    >> measure. Instantly any e-mail sent from an Online mailbox has the new
    >> Global Signature. Now here's the problem.... any e-mail sent in Caching
    >> mode still uses the outdated/old Global Signature.
    >>
    >> Steps to try correct the problem:
    >>
    >> Send/Receive
    >> Retrieve Contacts
    >> Switch to online mode and back to Caching mode
    >> Update Address books set to 1 day
    >> GWCheck | analyse/Fix | Contents | User database (from Admin Console)
    >> Retrieve Entire Mailbox
    >> Tools | Repair Mailbox | Analyse/Fix | Contents | User database (inside
    >> Caching Mailbox)
    >>
    >> None of the above updated the Global Signature on my Caching mailbox.
    >>
    >> Further testing:
    >>
    >> On POA set Global Signature to NONE and restart POA. E-mail sent from
    >> both Online and Caching mailbox has no Global Signature attached. On POA
    >> set Global Signature back to the one that was amended and restart POA.
    >> Caching mailbox still sends e-mail with outdated/old Global Signature.
    >> Scheduled maintenance has been running as per schedule on POA both
    >> Structure check each night and a full Content check on Friday night.
    >> This made no difference.
    >>
    >> Now here's the really weird thing, after approximately four days (give
    >> or take an hour or two) the Global Signature on the Caching mailbox
    >> updated.
    >>
    >> Rinse
  • Hi Mary,

    All the testing I've done has been on the R2 version. Thanks for the SR number.

    Please keep us posted.

    Cheers,
  • Hi Mary,

    Just an update from my side..... Novell are working on this issue. There is a bug logged in their internal bug tracking system. As and when I get more information I'll keep you updated :)

    Cheers,
  • When all else fails, jiggle the handle:

    Support couldn't duplicate this even with a copy of our system. So
    while on a remote session with a support engineer, he said "why not see
    what happens when you click that 'Restore Default Settings' button?"

    Because I had previously fiddled with global defaults at every possible
    level, I went through and pressed that restore button at every level.
    That solved the problem for most users. For the remaining ones, cycling
    through selecting one signature then another, along with some extra
    "restore default" pressing, seems to be getting the proper signature to
    be applied.

    Now, we've got a change of global signature coming up on the first of
    May...will see what chaos that creates.


    On 1/22/2016 12:36 AM, laurabuckley wrote:
    >
    > Hi Mary,
    >
    > Just an update from my side..... Novell are working on this issue.
    > There is a bug logged in their internal bug tracking system. As and
    > when I get more information I'll keep you updated :)
    >
    > Cheers,
    >
    >


Reply
  • When all else fails, jiggle the handle:

    Support couldn't duplicate this even with a copy of our system. So
    while on a remote session with a support engineer, he said "why not see
    what happens when you click that 'Restore Default Settings' button?"

    Because I had previously fiddled with global defaults at every possible
    level, I went through and pressed that restore button at every level.
    That solved the problem for most users. For the remaining ones, cycling
    through selecting one signature then another, along with some extra
    "restore default" pressing, seems to be getting the proper signature to
    be applied.

    Now, we've got a change of global signature coming up on the first of
    May...will see what chaos that creates.


    On 1/22/2016 12:36 AM, laurabuckley wrote:
    >
    > Hi Mary,
    >
    > Just an update from my side..... Novell are working on this issue.
    > There is a bug logged in their internal bug tracking system. As and
    > when I get more information I'll keep you updated :)
    >
    > Cheers,
    >
    >


Children