Error 820D - Invalid database - truncated to 0 bytes

Hi Forum.

I'm importing Mail into an account and every time I ran into the following error when the ofuser DB file size hit the 2gb.

POA Log:
10:05:37 F403 The database function 44 reported error [820D] on userq4f.db
10:05:37 F403 Error: File size is too large [820D] User:$USER ($USER)


GWcheck log:
STRUCTURAL VERIFICATION of database /media/nss/$DIR/ofuser/userq4f.db
Error 42- Invalid database - truncated to 0 bytes
Suggestion- No direct recovery possible. Attempt to recover file from external backup.
If no backup exists, request explicit structural rebuild from Admin and the
database will be replaced by valid empty database, to allow re-create.
However, all data previously contained in the database will be lost!


It seems to me that there is a limitation somewhere but I don't get exact information where?
I found nothing about the 820D in the error code documentation...

Someone experienced this ever? Can someone explain that?

Thanks in advance,
Pascal
  • Hi Pascal

    There is a limit of 2GB on the user database.

    You need to find out why the user database is growing to such proportion.

    Cheers,
  • Hi,

    what tools should I use to analyze a user DB and for what should I search?
    IMHO the user db just hold mails up to 2kb size and/or a pointer to the rest of the mail e.g. attachments and so on...

    Is there a work arround besides to create a new account and import mails there?


    Cheers,
    Pascal
  • Hi Pascal

    What tool are you using to import mail?

    You are right, the user DB just contains pointers, that's why it should never be so big!

    Cheers,
  • bendeichp;2271470 wrote:
    Hi,

    what tools should I use to analyze a user DB and for what should I search?


    Try the GroupWise client? Look at the user's mail.

    You can look at a recent GWCHECK log, like your weekly maintanance, it may ( or can ) show the number of items in each account.

    In most cases, its going to be an automated tool which is syncing mail like Google or a "no so smart" phone. There are a number of bugs in these things which can cause mail to be duplicated continuously. Typically we see the "Sent" folder ( rather than "Sent Items" ) You could also have a mail loop which has gone undetected. GW is usually good about breaking these, but its not possible to anticipate every type of loop.

    -- Bob
  • Hi,

    I use the GroupWise 5.x Archive FID Editor 1.0 to migrate mails from one account to another.
    Here are the stats of this account:

    - Current time 6:30:18 pm
    CONTENTS VERIFICATION/STATISTICS analysis of db /media/nss/xx/ofuser/userq4f.db
    - 845898 records found, last DRN = 846349
    ....
    User stats: 391011 InBox, 22111 OutBox, 100 WasteBasket
    Disk space management values: Size Limit - 0KB, Threshold - 0%
    24229956 kbytes in use by user's mail


    Are the "845898 records" pointers to other data of this account? What would be a "normal" value?
    I know its a big account but we have bigger ones with up to 60Gb in the gwcheck log.
    The user db of that 60gb account has only a size of 267M with 156308 records.

    (Unfortunately my boss went deaf as soon as I bring up mailbox size limits...)

    Maybe the user db increases faster when I use this way to migrate mails?

    Cheers,
    Pascal
  • Hi Pascal,

    As Bob mentions, you may have a "looping" mail somewhere.

    You could try a standalone GWCheck:

    Launch GWCheck.
    Fill in the Path to the Post Office.
    Fill in the Post Office name as it appears in ConsoleOne.
    Select Object Type and type in the ballooned db name in question. For Example, if msg2.db was the database in question: msg2.db
    Under the drop-down Action menu choose Analyze / Fix Databases, and check only "Contents" and "Fix problems."
    At the bottom right of the GWCheck Screen select the Misc. tab.
    In the Support Options: type in SUBJECTLIST (all caps). This will create a file called SUBDUMP in the same folder that you are running GWCheck from.
    After the GWCheck finishes, review the subdump file for suspected repeating messages.

    Let us know how it goes.

    Cheers,
  • Hi Laura,

    I did the steps three times but no SUBDUMP file was created. Last time i ran it with the verbose flag...

    Here are my gwcheck options:


    Processing information for this run:
    Path to PO = /media/nss/xx/xx
    Post Office= xx_PO
    User = userq4f.db
    Action = Analyze/Fix
    Files = Message, User
    Verify = Structure/Contents
    Fixup num = All
    Statistics = No
    Verbose = Yes
    Upd DiskSpace= No
    Output log = /root/gw_xx.log
    Misc Options = SUBJECTLIST


    Did I miss something?

    Thanks,
    Pascal
  • Hi Pascal,

    Map a drive from a windows workstation to your GroupWise nss volume and try running the GWCheck from a Windows workstation. Don't specify an output log file, let it create it automatically.

    Let us know how it goes.

    Cheers,
  • Hi Laura,

    done with the options:

    <?xml version="1.0" encoding="UTF-8"?>
    <GWCheck database-path="L:\XX_PO">
    <database-type>
    <post-office>
    <post-office-name>
    XX_PO
    </post-office-name>
    <object-type>
    <user-resource>
    <name>
    userq4f.db
    </name>
    </user-resource>
    </object-type>
    </post-office>
    </database-type>
    <action name="analyze-fix-database">
    <contents/>
    <fix-problems/>
    </action>
    <process-option>
    <databases>
    <user/>
    <message/>
    </databases>
    <logging>
    <file>
    gwchk32.log
    </file>
    </logging>
    <results>
    <send-to>
    <admin/>
    </send-to>
    </results>
    <misc>
    <support-option>
    SUBJECTLIST
    </support-option>
    </misc>
    </process-option>
    </GWCheck>


    But there is nothing in the folder from where I gwcheck.exe started.... Any other suggestions?

    Thanks,
    Pascal
  • Hi Pascal,

    Try to specify the user name in the field for User/Resource and check both user and message db with the Misc. option of SUBJECTLIST.

    Let us know how that goes.

    Cheers,