How to stop nightly db upkeep?

Is there a way to kill nightly indexing and other administrative post
office database upkeep jobs once they've started?


  • Hi Mike,

    For what reason would you want to do this?

    These routines are essential to a healthy GroupWise system.

    Cheers,
  • All of my Post Offices connect to a FC SAN disk array. The disk array
    has been having problems lately in that it's having a high rate of hard
    drive failures. When a drive fails the array rebuilds automatically to
    spare drive(s). While the array rebuild is occuring disk performance
    takes a hit. When disk performance takes a hit indexing and nightly db
    upkeep takes a lot longer then normal. When indexing and nightly db
    upkeep take a lot longer then normal, the jobs run into the next work
    day and Groupwise client performance takes a big hit once clients start
    connecting in the morning. I'm not asking to remove the upkeep jobs
    from the scheduler. I'm asking how to stop a job once it's started to
    allow disk rebuilds to finish sooner which then allow db upkeep jobs to
    finish sooner which will allow clients to not become essentially
    unusably slow because so many things are trying to occur at the same
    time. One day of missing upkeep jobs should not be a problem for any
    Groupwise system. If I restart the POA or even the entire server will
    the upkeep jobs automatically restart or would that be sufficient to
    kill the jobs for a day?





    On 3/12/2015 11:06 AM, laurabuckley wrote:
    >
    > Hi Mike,
    >
    > For what reason would you want to do this?
    >
    > These routines are essential to a healthy GroupWise system.
    >
    > Cheers,
    >
    >


  • Hi Mike,

    I'm sorry to read about your situation - I do hope that it improves soon.

    As far as I am aware a simple stop/start of the POA will kill the jobs, but I have not tested this in a long time :(

    Cheers,
  • laurabuckley;2349569 wrote:
    As far as I am aware a simple stop/start of the POA will kill the jobs, but I have not tested this in a long time


    Yep, that will stop the maintenance jobs and they should not rerun when starting the POA back up (until the next scheduled job is up, which you might want to temporarily disable as long as the SAN rebuild is going on. Just untick any maintenance jobs -just leaving the disk check job enabled - as mentioned here: https://www.novell.com/documentation/groupwise2012/gw2012_guide_admin/data/ak8heyi.html).

    As added note (and in case you are not aware of it): Little things might help giving some air like turning off salvage (if it's NSS and the option is enabled), setting the volume read ahead to 2 of 0 (also if this is NSS) and use the "noatime" option (generic option for many filesystems).

    Hope the disk situation sorts out quickly.... never fun, those type of things.

    Cheers,
    Willem