HowTo: POA accessible from multiple IP-Addresses

Hi

we need to migrate our internal IP-Range and decided to bind at the same time the new (and the old) IP-Range to all of our Servers (NetWare / OES2 / OES11).
This is also true for our OES11 SP1 Server running GroupWise 2012
How can we achieve that the POA is accessible from both IP-Ranges.

The documentation says that POA will bind to all available internal IP-Addresses if none is explicitly declared.
We tried clearing the IP-Address in ConsoleOne on the POA but that did have no effect. POA did still only bind on the old IP-Address.

Thanks
Andrej

Tags:

  • Hi Andrej,

    Basic thing, but I have to check.... ensure that you don't have the "Bind Exclusive" box ticked below the POA IP address in ConsoleOne.

    Also check the POA startup file to ensure that the IP of the POA has not been explicitly set there.

    GroupWise agents are normally rather "promiscuous" and bind to all available IP's unless expressly told not to do so!

    Let us know how it goes.

    Cheers,
  • In article <53330280.8808.0090.1@kabe-farben.ch>, Andrej Dimic wrote:
    > How can we achieve that the POA is accessible from both IP-Ranges.

    As per Laura's post make sure 'bind exclusive' is not selected, and
    then you may have to stop and start the agents for them to listen.

    To check on Linux what your agents are listing on
    netstat -pln | grep gw

    example output of POA on all IPs and a GWIA on just one IP
    tcp 0 0 0.0.0.0:1677 0.0.0.0:* LISTEN 6634/gwpoa
    tcp 0 0 10.11.0.42:25 0.0.0.0:* LISTEN 6740/gwia



    Andy of
    KonecnyConsulting.ca in Toronto
    Knowledge Partner
    http://forums.novell.com/member.php/75037-konecnya
    If you find a post helpful and are logged in the Web interface, please
    show your appreciation by clicking on the star below. Thanks!

  • Hi Andy

    it works now, but i still do not understand every aspect how the IP-Address in POA is set.

    I tried clearing the IP-Address in the POA-Object. Netstat shows :::1677
    I tried setting 0.0.0.0 in the POA-Object. Netstat still shows :::1677 (should it not show 0.0.0.0:1677?)
    When i set /ip-0.0.0.0 in the POA-Startup File, netstat shows 0.0.0.0:1677

    but as i said, it works with :::1677.

    Thanks Andrej



    >>> Andy Konecny<konecnya@no-mx.forums.novell.com> 26.03.2014 20:43 >>>

    In article <53330280.8808.0090.1@kabe-farben.ch>, Andrej Dimic wrote:

    > How can we achieve that the POA is accessible from both IP-Ranges.

    As per Laura's post make sure 'bind exclusive' is not selected, and
    then you may have to stop and start the agents for them to listen.

    To check on Linux what your agents are listing on
    netstat -pln | grep gw

    example output of POA on all IPs and a GWIA on just one IP
    tcp 0 0 0.0.0.0:1677 0.0.0.0:* LISTEN 6634/gwpoa
    tcp 0 0 10.11.0.42:25 0.0.0.0:* LISTEN 6740/gwia



    Andy of
    KonecnyConsulting.ca in Toronto
    Knowledge Partner
    http://forums.novell.com/member.php/75037-konecnya
    If you find a post helpful and are logged in the Web interface, please
    show your appreciation by clicking on the star below. Thanks!
  • Hi.

    On 28.03.2014 09:12, Andrej Dimic wrote:
    > Hi Andy
    > it works now, but i still do not understand every aspect how the IP-Address in
    > POA is set.
    > I tried clearing the IP-Address in the POA-Object.


    That's fatal. The IP address in teh object is absolutely necessary, and
    must be a real, individual IP that is suitable for the other GW
    components to communicat with the POA. PLease set it back ASAP to a real
    individual IP address, and afterwards run a rebuild on the post office
    database. Otherwise your PO will most likely be cut off from the rest of
    the world.

    The only config necessary for your issue is, should the POA listen on
    only that one address it's configured for (the checkbox bind exclusively
    at the network address screen in consoleone), or does it listen on all
    addresses (the above mentioned checkbox is cleared).

    CU,
    --
    Massimo Rosen
    Novell Knowledge Partner
    No emails please!
    http://www.cfc-it.de
  • Hi Massimo

    ok, now i see and i did put in back a real IP-Address and i did clear the 'bind exclusive' checkbox.

    Problem is that we work on a german ConsoleOne and there it says 'Nur an TCP/IP-Adresse binden'.
    This translation is misleading (not to say wrong) as it is interpreted as bind only to the IP-Address and not to the IPX(SPX-Address (which is also in the POA-Network TAB.
    To make clear that the choice is to either bind only to the IP-Address supplied or bind to every IP-Address, one would have to write.
    'Nur an diese TCP/IP-Adresse binden'

    Thanks
    Andrej



    >>> Massimo Rosen<mrosenNO@SPAMcfc-it.de> 28.03.2014 18:53 >>>

    Hi.

    On 28.03.2014 09:12, Andrej Dimic wrote:

    > Hi Andy
    > it works now, but i still do not understand every aspect how the IP-Address in
    > POA is set.
    > I tried clearing the IP-Address in the POA-Object.


    That's fatal. The IP address in teh object is absolutely necessary, and
    must be a real, individual IP that is suitable for the other GW
    components to communicat with the POA. PLease set it back ASAP to a real
    individual IP address, and afterwards run a rebuild on the post office
    database. Otherwise your PO will most likely be cut off from the rest of
    the world.

    The only config necessary for your issue is, should the POA listen on
    only that one address it's configured for (the checkbox bind exclusively
    at the network address screen in consoleone), or does it listen on all
    addresses (the above mentioned checkbox is cleared).

    CU,
    --
    Massimo Rosen
    Novell Knowledge Partner
    No emails please!
    http://www.cfc-it.de
  • On 31.03.2014 08:26, Andrej Dimic wrote:
    > Hi Massimo
    > ok, now i see and i did put in back a real IP-Address and i did clear the 'bind
    > exclusive' checkbox.
    > Problem is that we work on a german ConsoleOne and there it says 'Nur an
    > TCP/IP-Adresse binden'.
    > This translation is misleading (not to say wrong) as it is interpreted as bind
    > only to the IP-Address and not to the IPX(SPX-Address (which is also in the
    > POA-Network TAB.
    > To make clear that the choice is to either bind only to the IP-Address supplied
    > or bind to every IP-Address, one would have to write.
    > 'Nur an diese TCP/IP-Adresse binden'


    Stimmt. Ist mir noch gar nicht so aufgefallen.

    In der ConsoelOne wird das aber sicher nicht mehr geändert werden, aber
    ich prüfe das mal in der neuen Konsole von GW 2014 ob das da immernoch
    so ist. Dann meld' ich das als bug.

    CU,
    --
    Massimo Rosen
    Novell Knowledge Partner
    No emails please!
    http://www.cfc-it.de