Archive not displaying any emails, mailbox rebuild fails

Hi, I've got a user whose archive had a problem. The original report was that he was not able to archive. When he attempted to archive anything he got an error ("c067 Database store # is invalid.")

After using gwcheck to rebuild the archive, this error no longer happens, however GW also does not show any of the ~330MB of emails in the archive. We looked around at every setting we could think of to make sure nothing was being filtered or hidden. I've tried changing the archive directory so that GW moves it and all of the archive files get moved properly. So GW seems to know that those files are there, but will not display them properly when viewing the archive.

I've also tried holding Ctrl Shift while opening the archive and letting it rebuild the mailbox. It gets past the first step, but just hangs on step 2/2. Closing the rebuild dialog causes GW to go unresponsive and it must be killed.

I have a copy of the archive from before we did anything to it, and a copy of it after we resolved the error. I'm not sure what I can do to try to recover this, or if it's even recoverable. Any further suggestions?

I am end-user support and do not run nor have any access to our GW database/server. Our server guys were the ones who ran gwcheck and got it to stop with the c067 error, but couldn't figure out why the archive won't show emails.
Our GW client is 8.0.2 1/8/2011, Build 92614.
Our basic systems here are Windows 7 64-bit (mostly SP1).