database corruption (0xDB21)

After validating the primary domain from the webconsole i encountered an error "database corruption (0xDB21), I have searched the internet if there are similar problems but I couldn't find any.

If someone could help or tell me what this error code is or its cause that would be appreciated.

I attached a screenshot of the error I encountered.

Thanks 

  • Yes I recovered the database, But I would just like to know what the error code (0xDB21) means? maybe there's a way to prevent these things to happen. 

    But Thank you for the reply, I appreciate it.

  • Verified Answer


     wrote:

    Yes I recovered the database, But I would just like to know what the error code (0xDB21) means? maybe there's a way to prevent these things to happen. 

    But Thank you for the reply, I appreciate it.


    This is what the documentation says about that error:

     

    DB21 Database inconsistency detected

    Source:GroupWise engine; administration engine.
    Explanation:Database invalid or damaged.
    Possible Cause:The database is invalid.
    Action:Rebuild the database. 
     
    The cause could be a lot of things.  Unfortunately we have no way to know what that cause was.
     
    Pam
  • That is unfortunate. Thanks pam

  • Hi could you give me examples of what could cause a database corruption?

     

    Thanks and Kind Regards,

    Lyle

  • Hi Lyle,

    maybe Pam can deliver some more precise examples.

    But my experiences showed me different reasons: virus scanner, hard disc failures or corrupt file system, of course power failures - and sometimes (rather rare) agent crashes.

    Laura has mentioned the self-healing process in the background.

    My recommendation is to create and run a secondary domain, every time - independent how small your GroupWise system is. So you have a chance to rebuild the primary whenever you need.

    Diethmar

     

  • Hello ,

    Yes, I do have a secondary domain to rebuild the primary domain. I would just like to know some causes on why it happens maybe I could pinpioint the cause on my part. I mostly checked everything from viruses to power failures but to no avail.

    What intrigues me is that a corrupt file system could be a cause to, is there a way to know that my file system is corrupted? i'm using SUSE12 as my OS for my GroupWise.

    Thanks and Kind Regards,

    Lyle

     

  • Hi Lyle,

    at one customer I have a strange situation of course. Every one or two month a wpdomain.db is corrupt on one of two servers. It is a larger environment with many domains. Those two servers which suffer these problems do not contain any postoffices. They host just a GWIA (plus domain) which is used for outgoing mails (SMTP relay for non GroupWise clients).

    Sometimes a wpdomain.db is corrupt. We have never find out the real problem. Now they are on version GW18.1.2 which improved the situation a lot (nowadays only one server every two months runs into this situation). With GW2014R2 we had corrupt databases on both servers every month.

    I have mentioned that we cannot(could not) find out the problem. Both servers have the same environment. Domain plus GWIA. Plus Gwava6.5. Gwava did the Gwia scan for outgoing mails. At this customer site there were more domain-GWIA bundles but with different roles.

    My description does not really help you except that GW18 has less problems ...

    Kind regards
    Diethmar

     

  • hello  ,

    The scenario you mentioned is kind of similar to what I'm experiencing right now. The corruption occurs every two months or less and it's very alarming.

    Could this be a problem with the software itself? or software issue?

    Thanks and Kind Regards,

    Lyle

  • "I mostly checked everything from viruses to..."

    Not sure what you mean by this, but if you have anti-virus installed on your GroupWise servers, you absolutely should not be scanning any of your domain or post office folders.  That will cause issues.